Skip to content

langchain (PyPI)

Advisories
48
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.3.9 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "langchain>=1.3.9"
poetry
poetry add "langchain>=1.3.9"
uv
uv add "langchain>=1.3.9"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-gr75-jv2w-4656
LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Medium
EPSS 0.21%
< 1.3.9
1.3.9
GHSA-gr75-jv2w-4656
LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Medium
EPSS 0.21%
< 1.3.9
1.3.9
GHSA-3644-q5cj-c5c7
LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
High
EPSS 0.20%
< 0.3.30
0.3.30
GHSA-3644-q5cj-c5c7
LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
High
EPSS 0.20%
< 0.3.30
0.3.30
GHSA-45pg-36p6-83v9
Langchain SQL Injection vulnerability
Critical
EPSS 13.74%
< 0.2.0
0.2.0
GHSA-45pg-36p6-83v9
Langchain SQL Injection vulnerability
Critical
EPSS 13.74%
< 0.2.0
0.2.0
GHSA-45pg-36p6-83v9
Langchain SQL Injection vulnerability
Critical
EPSS 13.74%
< 0.2.0
0.2.0
PYSEC-2024-114
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection,…
Withdrawn
Critical
< 0.3.1
0.3.1
PYSEC-2024-111
A path traversal vulnerability exists in the `getFullPath` method of langchain-ai/langchainjs version 0.2.5.
Withdrawn
Critical
all versions
No fix yet
PYSEC-2024-323
LangChain pickle deserialization of untrusted data
High
EPSS 0.36%
< 0.2.9
0.2.9
GHSA-3hjh-jh2h-vrg6
Denial of service in langchain-community
Medium
EPSS 0.30%
< 0.2.5
0.2.5
GHSA-3hjh-jh2h-vrg6
Denial of service in langchain-community
Medium
EPSS 0.30%
< 0.2.5
0.2.5
GHSA-rgp8-pm28-3759
langchain vulnerable to path traversal
High
EPSS 1.87%
< 0.0.353
0.0.353
GHSA-rgp8-pm28-3759
langchain vulnerable to path traversal
High
EPSS 1.87%
< 0.0.353
0.0.353
GHSA-h59x-p739-982c
LangChain directory traversal vulnerability
High
EPSS 1.74%
< 0.1.11
0.1.11
GHSA-h59x-p739-982c
LangChain directory traversal vulnerability
High
EPSS 1.74%
< 0.0.339
0.0.339
GHSA-h9j7-5xvc-qhg5
langchain Server-Side Request Forgery vulnerability
High
EPSS 0.52%
< 0.1.0
0.1.0
GHSA-h9j7-5xvc-qhg5
langchain Server-Side Request Forgery vulnerability
High
EPSS 0.52%
< 0.1.0
0.1.0
GHSA-6h8p-4hx9-w66c
Langchain Server-Side Request Forgery vulnerability
High
EPSS 0.71%
< 0.0.329
0.0.329
GHSA-6h8p-4hx9-w66c
Langchain Server-Side Request Forgery vulnerability
High
EPSS 0.71%
< 0.0.329
0.0.329
GHSA-8h5w-f6q9-wg35
Langchain SQL Injection vulnerability
Critical
< 0.0.247
0.0.247
GHSA-8h5w-f6q9-wg35
Langchain SQL Injection vulnerability
Critical
< 0.0.247
0.0.247
GHSA-655w-fm8m-m478
LangChain Server Side Request Forgery vulnerability
High
EPSS 47.62%
< 0.0.317
0.0.317
GHSA-655w-fm8m-m478
LangChain Server Side Request Forgery vulnerability
High
EPSS 47.62%
< 0.0.317
0.0.317
GHSA-f73w-4m7g-ch9x
Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
Critical
EPSS 1.60%
< 0.0.308
0.0.308
GHSA-f73w-4m7g-ch9x
Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
Critical
EPSS 1.60%
< 0.0.308
0.0.308
GHSA-7gfq-f96f-g85j
langchain vulnerable to arbitrary code execution
Critical
EPSS 3.44%
< 0.0.312
0.0.312
GHSA-7gfq-f96f-g85j
langchain vulnerable to arbitrary code execution
Critical
EPSS 3.44%
< 0.0.171
0.0.171
GHSA-fj32-q626-pjjc
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.42%
< 0.0.247
0.0.247
GHSA-92j5-3459-qgp4
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.84%
< 0.0.236
0.0.236
GHSA-92j5-3459-qgp4
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.84%
< 0.0.195
0.0.195
GHSA-fj32-q626-pjjc
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.42%
< 0.0.247
0.0.247
GHSA-prgp-w7vf-ch62
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.53%
< 0.0.325
0.0.325
GHSA-prgp-w7vf-ch62
LangChain vulnerable to arbitrary code execution
Critical
EPSS 1.53%
< 0.0.233
0.0.233
GHSA-gwqq-6vq7-5j86
langchain Code Injection vulnerability
Critical
EPSS 1.17%
< 0.0.236
0.0.236
GHSA-gwqq-6vq7-5j86
langchain Code Injection vulnerability
Critical
EPSS 1.17%
< 0.0.236
0.0.236
GHSA-7q94-qpjr-xpgm
langchain SQL Injection vulnerability
High
EPSS 1.25%
< 0.0.247
0.0.247
GHSA-57fc-8q82-gfp3
langchain vulnerable to arbitrary code execution
Critical
EPSS 1.90%
< 0.0.247
0.0.247
GHSA-57fc-8q82-gfp3
langchain vulnerable to arbitrary code execution
Critical
EPSS 1.90%
< 0.0.247
0.0.247
GHSA-7q94-qpjr-xpgm
langchain SQL Injection vulnerability
High
EPSS 1.25%
< 0.0.247
0.0.247
GHSA-2qmj-7962-cjq8
langchain arbitrary code execution vulnerability
Critical
EPSS 1.07%
< 0.0.247
0.0.247
GHSA-2qmj-7962-cjq8
langchain arbitrary code execution vulnerability
Critical
EPSS 1.07%
< 0.0.247
0.0.247
GHSA-6643-h7h5-x9wh
Langchain vulnerable to arbitrary code execution
Critical
EPSS 0.94%
< 0.0.247
0.0.247
GHSA-6643-h7h5-x9wh
Langchain vulnerable to arbitrary code execution
Critical
EPSS 0.94%
< 0.0.247
0.0.247
GHSA-x32c-59v5-h7fg
Langchain OS Command Injection vulnerability
Critical
EPSS 1.68%
< 0.0.225
0.0.225
GHSA-x32c-59v5-h7fg
Langchain OS Command Injection vulnerability
Critical
EPSS 1.68%
< 0.0.225
0.0.225
GHSA-fprp-p869-w6q2
LangChain vulnerable to code injection
Critical
EPSS 39.65%
< 0.0.132
0.0.132
GHSA-fprp-p869-w6q2
LangChain vulnerable to code injection
Critical
EPSS 39.65%
<= 0.0.131
No fix yet
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor