Skip to content

GHSA-prgp-w7vf-ch62 CVE-2023-39659 PYSEC-2023-147

LangChain vulnerable to arbitrary code execution

Critical PyPI
Severity
0.0 / 10
Critical · CVSS 4.0
Exploit chance (EPSS)
1.53%
Chance of exploitation in the next 30 days. Higher than 74.82% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
Fix
0.0.325
Upgrade langchain to this version or later

Description

An issue in langchain langchain-ai before version 0.0.325 allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.

Affected versions

PyPI

PackageVulnerableFixed in
langchain
< 0.0.325
0.0.325
langchain
< 0.0.233
0.0.233

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

langchain PyPI → 0.0.325

pip
pip install --upgrade "langchain>=0.0.325"
poetry
poetry add "langchain>=0.0.325"
uv
uv add "langchain>=0.0.325"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
None
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 9.8

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

The product constructs all or part of a command, data structure, or record using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify how it is parsed or interpreted when it is sent to a downstream component.

How to prevent it
  • Requirements: Programming languages and supporting technologies might be chosen which are not subject to these issues.
  • Implementation: Utilize an appropriate mix of allowlist and denylist parsing to filter control-plane syntax from all input.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gr75-jv2w-4656
LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Medium Also affects langchain
GHSA-3644-q5cj-c5c7
LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
High Also affects langchain
GHSA-45pg-36p6-83v9
Langchain SQL Injection vulnerability
Critical Also affects langchain
PYSEC-2024-323
LangChain pickle deserialization of untrusted data
High Also affects langchain
GHSA-3hjh-jh2h-vrg6
Denial of service in langchain-community
Medium Also affects langchain
GHSA-rgp8-pm28-3759
langchain vulnerable to path traversal
High Also affects langchain
GHSA-h59x-p739-982c
LangChain directory traversal vulnerability
High Also affects langchain
GHSA-h9j7-5xvc-qhg5
langchain Server-Side Request Forgery vulnerability
High Also affects langchain
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor