Skip to content

PYSEC-2024-114

A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection,…

Critical Withdrawn Jun 7, 2025 PyPI
Severity
9.8 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
0.3.1
Upgrade langchain to this version or later

Description

A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

Affected versions

PyPI

PackageVulnerableFixed in
langchain
< 0.3.1
0.3.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

langchain PyPI → 0.3.1

pip
pip install --upgrade "langchain>=0.3.1"
poetry
poetry add "langchain>=0.3.1"
uv
uv add "langchain>=0.3.1"

Severity breakdown

CVSS 3.1 9.8

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

References

Timeline

  1. Published
  2. Last updated by the source
  3. Withdrawn
AdvisorySeverityWhy it's related
GHSA-gr75-jv2w-4656
LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Medium Also affects langchain
GHSA-3644-q5cj-c5c7
LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
High Also affects langchain
GHSA-45pg-36p6-83v9
Langchain SQL Injection vulnerability
Critical Also affects langchain
PYSEC-2024-323
LangChain pickle deserialization of untrusted data
High Also affects langchain
GHSA-3hjh-jh2h-vrg6
Denial of service in langchain-community
Medium Also affects langchain
GHSA-rgp8-pm28-3759
langchain vulnerable to path traversal
High Also affects langchain
GHSA-h59x-p739-982c
LangChain directory traversal vulnerability
High Also affects langchain
GHSA-h9j7-5xvc-qhg5
langchain Server-Side Request Forgery vulnerability
High Also affects langchain
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor