GHSA-655w-fm8m-m478 CVE-2023-46229 PYSEC-2023-205
LangChain Server Side Request Forgery vulnerability
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 47.62%
- Chance of exploitation in the next 30 days. Higher than 98.85% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-918 Server-Side Request Forgery (SSRF)
- Fix
0.0.317- Upgrade langchain to this version or later
Description
LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to an internal server.
Affected versions
PyPI
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
langchain PyPI → 0.0.317
- pip
pip install --upgrade "langchain>=0.0.317"- poetry
poetry add "langchain>=0.0.317"- uv
uv add "langchain>=0.0.317"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- Active
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-918: Server-Side Request Forgery (SSRF)
The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gr75-jv2w-4656 LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders | Medium | Also affects langchain |
| GHSA-3644-q5cj-c5c7 LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning | High | Also affects langchain |
| GHSA-45pg-36p6-83v9 Langchain SQL Injection vulnerability | Critical | Also affects langchain |
| PYSEC-2024-323 LangChain pickle deserialization of untrusted data | High | Also affects langchain |
| GHSA-3hjh-jh2h-vrg6 Denial of service in langchain-community | Medium | Also affects langchain |
| GHSA-rgp8-pm28-3759 langchain vulnerable to path traversal | High | Also affects langchain |
| GHSA-h59x-p739-982c LangChain directory traversal vulnerability | High | Also affects langchain |
| GHSA-h9j7-5xvc-qhg5 langchain Server-Side Request Forgery vulnerability | High | Also affects langchain |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor