GHSA-vxf6-w9mp-95hm CVE-2012-3408
Puppet supports use of IP addresses in certnames without warning of potential risks
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 1.64%
- Chance of exploitation in the next 30 days. Higher than 76.39% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
2.7.18- Upgrade puppet to this version or later
Description
lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which might allow remote attackers to spoof an agent by acquiring a previously used IP address.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| puppet | < 2.7.18 |
2.7.18 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
puppet RubyGems → 2.7.18
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.7.18"
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mpmx-gm5v-q789 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-9pvx-fwwh-w289 Puppet does not properly restrict access to node resources | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor