GHSA-9pvx-fwwh-w289 CVE-2011-0528
Puppet does not properly restrict access to node resources
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 1.65%
- Chance of exploitation in the next 30 days. Higher than 76.54% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-284 Improper Access Control
- Fix
2.6.4- Upgrade puppet to this version or later
Description
Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| puppet | >= 2.6.0, < 2.6.4 |
2.6.4 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
puppet RubyGems → 2.6.4
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.6.4"
Weakness
CWE-284: Improper Access Control
The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor.
How to prevent it
- Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/puppetlabs/puppet/commit/eee1a9cdaa5cab6222c8e6ab087d319f976fa4e3
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2011-0528.yml
- mail-archive.com/puppet-users@googlegroups.com/msg16429.html
- openwall.com/lists/oss-security/2011/01/27/6
- openwall.com/lists/oss-security/2011/01/31/5
- ubuntu.com/usn/USN-1365-1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mpmx-gm5v-q789 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
| GHSA-vw22-465p-8j5w Tarball permission preservation in puppet | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor