GHSA-mpmx-gm5v-q789 CVE-2011-3871
Puppet uses predictable filenames, allowing arbitrary file overwrite
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.34%
- Chance of exploitation in the next 30 days. Higher than 27.29% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-340 Generation of Predictable Numbers or Identifiers
- Fix
2.7.5- Upgrade puppet to this version or later
Description
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.
Affected versions
RubyGems
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
puppet RubyGems → 2.7.5
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.7.5"
Weakness
CWE-340: Generation of Predictable Numbers or Identifiers
The product uses a scheme that generates numbers or identifiers that are more predictable than required.
References
Advisories
Packages
Other links
- github.com/puppetlabs/puppet/commit/343c7bd381b63e042d437111718918f951d9b30d
- github.com/puppetlabs/puppet/commit/d76c30935460ded953792dfe49f72b8c5158e899
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2011-3871.yml
- puppet.com/security/cve/cve-2011-3871
- groups.google.com/group/puppet-announce/browse_thread/thread/91e3b46d2328a1cb
- lists.fedoraproject.org/pipermail/package-announce/2011-October/068053.html
- lists.fedoraproject.org/pipermail/package-announce/2011-October/068061.html
- lists.fedoraproject.org/pipermail/package-announce/2011-October/068093.html
- debian.org/security/2011/dsa-2314
- ubuntu.com/usn/USN-1223-1
- ubuntu.com/usn/USN-1223-2
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9pvx-fwwh-w289 Puppet does not properly restrict access to node resources | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
| GHSA-vw22-465p-8j5w Tarball permission preservation in puppet | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor