Skip to content

GHSA-c4mc-49hq-q275 CVE-2012-1906

Puppet uses predictable filenames, allowing arbitrary file overwrite

Medium RubyGems
Severity
Medium
The publisher's own rating, not a CVSS score
Exploit chance (EPSS)
0.35%
Chance of exploitation in the next 30 days. Higher than 28.65% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-377 Insecure Temporary File
Fix
2.6.15
Upgrade puppet to this version or later

Description

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac OS X packages from a remote source, which allows local users to overwrite arbitrary files or install arbitrary packages via a symlink attack on a temporary file in /tmp.

Affected versions

RubyGems

PackageVulnerableFixed in
puppet
>= 2.6, < 2.6.15
2.6.15
puppet
>= 2.7, < 2.7.13
2.7.13

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

puppet RubyGems → 2.6.15

bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.6.15"

Weakness

CWE-377: Insecure Temporary File

Creating and using insecure temporary files can leave application and system data vulnerable to attack.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-mpmx-gm5v-q789
Puppet uses predictable filenames, allowing arbitrary file overwrite
Medium Also affects puppet
GHSA-9pvx-fwwh-w289
Puppet does not properly restrict access to node resources
Medium Also affects puppet
GHSA-qh3g-27jf-3j54
Puppet allows local users to modify the permissions of arbitrary files
Medium Also affects puppet
GHSA-8c56-v25w-f89c
Puppet arbitrary file overwrite
Medium Also affects puppet
GHSA-v58w-6xc2-w799
Puppet Denial of Service and Arbitrary File Write
Low Also affects puppet
GHSA-6xxq-j39w-g3f6
Puppet Arbitrary Command Execution
Medium Also affects puppet
GHSA-77hg-g8cc-5r37
Puppet Privilege Escallation
Medium Also affects puppet
GHSA-vw22-465p-8j5w
Tarball permission preservation in puppet
Medium Also affects puppet
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor