GHSA-q44r-f2hm-v76v CVE-2012-3867
Pupper does not properly restrict characters in Common Name field of Certificate Signing Request
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 2.45%
- Chance of exploitation in the next 30 days. Higher than 84.40% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
2.6.17- Upgrade puppet to this version or later
Description
lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the Common Name field of a Certificate Signing Request (CSR), which makes it easier for user-assisted remote attackers to trick administrators into signing a crafted agent certificate via ANSI control sequences.
Affected versions
RubyGems
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
puppet RubyGems → 2.6.17
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.6.17"
References
Advisories
Packages
Other links
- github.com/puppetlabs/puppet/commit/dfedaa5fa841ccf335245a748b347b7c7c236640
- github.com/puppetlabs/puppet/commit/f3419620b42080dad3b0be14470b20a972f13c50
- bugzilla.redhat.com/show_bug.cgi
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-3867.yml
- puppet.com/security/cve/cve-2012-3867-insufficient-input-validation
- lists.opensuse.org/opensuse-security-announce/2012-08/msg00006.html
- lists.opensuse.org/opensuse-updates/2012-07/msg00036.html
- puppetlabs.com/security/cve/cve-2012-3867
- debian.org/security/2012/dsa-2511
- ubuntu.com/usn/USN-1506-1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mpmx-gm5v-q789 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-9pvx-fwwh-w289 Puppet does not properly restrict access to node resources | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor