GHSA-mc6j-h948-v2p6 CVE-2018-1000076
RubyGems Improper Verification of Cryptographic Signature vulnerability
- Severity
- 9.8 / 10
- Critical · CVSS 3.0
- Exploit chance (EPSS)
- 2.93%
- Chance of exploitation in the next 30 days. Higher than 87.10% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-347 Improper Verification of Cryptographic Signature
- Fix
- Available
- 2 packages have a fixed version
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, and Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contain an Improper Verification of Cryptographic Signature vulnerability in package.rb. This can result in a mis-signed gem being installed, as the tarball would contain multiple gem signatures. This vulnerability has been fixed in 2.7.6.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.jruby:jruby-stdlib | < 9.1.16.0 |
9.1.16.0 |
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rubygems-update | >= 2.2.0, < 2.7.6 |
2.7.6 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.jruby:jruby-stdlib Maven → 9.1.16.0
- maven
<dependency><groupId>org.jruby</groupId><artifactId>jruby-stdlib</artifactId><version>9.1.16.0</version></dependency>- gradle
implementation("org.jruby:jruby-stdlib:9.1.16.0")
rubygems-update RubyGems → 2.7.6
- bundler
bundle update rubygems-update # Gemfile: gem "rubygems-update", ">= 2.7.6"
Severity breakdown
CVSS 3.0 9.8
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-347: Improper Verification of Cryptographic Signature
The product does not verify, or incorrectly verifies, the cryptographic signature for data.
References
Advisories
Packages
Other links
- github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- github.com/rubygems/rubygems/commit/f5042b879259b1f1ce95a0c5082622c646376693
- debian.org/security/2018/dsa-4259
- debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1
- lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- lists.debian.org/debian-lts-announce/2018/04/msg00000.html
- access.redhat.com/errata/RHSA-2020:0663
- access.redhat.com/errata/RHSA-2020:0591
- access.redhat.com/errata/RHSA-2020:0542
- access.redhat.com/errata/RHSA-2019:2028
- access.redhat.com/errata/RHSA-2018:3731
- access.redhat.com/errata/RHSA-2018:3730
- access.redhat.com/errata/RHSA-2018:3729
- blog.rubygems.org/2018/02/15/2.7.6-released.html
- lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-228f-g3h7-3fj3 RubyGems HTTPS to HTTP redirect | Medium | Also affects rubygems-update |
| GHSA-5mgj-mvv8-46mw RubyGems does not verify SSL certificate | Medium | Also affects rubygems-update |
| GHSA-qv62-xfj6-32xm RubyGems Improper Input Validation vulnerability | Medium | Also affects rubygems-update |
| GHSA-9qvm-2vhf-q649 RubyGems Regular Expression Denial of Service | Medium | Also affects rubygems-update |
| GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability | Medium | Also affects org.jruby:jruby-stdlib |
| GHSA-wp3j-rvfp-624h RubyGems vulnerable to DNS hijack attack | High | Also affects rubygems-update |
| GHSA-9j7m-rjqx-48vh RubyGems Regular Expression Denial of Service vulnerability | Medium | Also affects rubygems-update |
| GHSA-p7f2-rr42-m9xm RubyGems Improper Input Validation vulnerability | High | Also affects rubygems-update |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor