GHSA-9qvm-2vhf-q649 CVE-2013-4363
RubyGems Regular Expression Denial of Service
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 1.69%
- Chance of exploitation in the next 30 days. Higher than 77.07% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
1.8.23.2- Upgrade rubygems-update to this version or later
Description
Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rubygems-update | < 1.8.23.2 |
1.8.23.2 |
| rubygems-update | >= 1.8.24, < 1.8.27 |
1.8.27 |
| rubygems-update | >= 2.0.0, < 2.0.10 |
2.0.10 |
| rubygems-update | >= 2.1.0, < 2.1.5 |
2.1.5 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
rubygems-update RubyGems → 1.8.23.2
- bundler
bundle update rubygems-update # Gemfile: gem "rubygems-update", ">= 1.8.23.2"
References
Advisories
Packages
Other links
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2013-4…
- web.archive.org/web/20170331150441/https://puppet.com/security/cve/cve-2013-4363
- blog.rubygems.org/2013/09/24/CVE-2013-4363.html
- openwall.com/lists/oss-security/2013/09/14/3
- openwall.com/lists/oss-security/2013/09/18/8
- openwall.com/lists/oss-security/2013/09/20/1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-228f-g3h7-3fj3 RubyGems HTTPS to HTTP redirect | Medium | Also affects rubygems-update |
| GHSA-5mgj-mvv8-46mw RubyGems does not verify SSL certificate | Medium | Also affects rubygems-update |
| GHSA-qv62-xfj6-32xm RubyGems Improper Input Validation vulnerability | Medium | Also affects rubygems-update |
| GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability | Medium | Also affects rubygems-update |
| GHSA-wp3j-rvfp-624h RubyGems vulnerable to DNS hijack attack | High | Also affects rubygems-update |
| GHSA-9j7m-rjqx-48vh RubyGems Regular Expression Denial of Service vulnerability | Medium | Also affects rubygems-update |
| GHSA-p7f2-rr42-m9xm RubyGems Improper Input Validation vulnerability | High | Also affects rubygems-update |
| GHSA-qj2w-mw2r-pv39 RubyGems Deserialization of Untrusted Data vulnerability | High | Also affects rubygems-update |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor