Skip to content

GHSA-9j7m-rjqx-48vh CVE-2013-4287

RubyGems Regular Expression Denial of Service vulnerability

Medium RubyGems
Severity
Medium
The publisher's own rating, not a CVSS score
Exploit chance (EPSS)
3.33%
Chance of exploitation in the next 30 days. Higher than 88.62% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-400 Uncontrolled Resource Consumption
Fix
1.8.23.1
Upgrade rubygems-update to this version or later

Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

Affected versions

RubyGems

PackageVulnerableFixed in
rubygems-update
< 1.8.23.1
1.8.23.1
rubygems-update
>= 1.8.24, < 1.8.26
1.8.26
rubygems-update
>= 2.0.0, < 2.0.8
2.0.8
rubygems-update
>= 2.1.0.rc.1, < 2.1.0
2.1.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

rubygems-update RubyGems → 1.8.23.1

bundler
bundle update rubygems-update # Gemfile: gem "rubygems-update", ">= 1.8.23.1"

Weakness

CWE-400: Uncontrolled Resource Consumption

The product does not properly control the allocation and maintenance of a limited resource.

How to prevent it
  • Architecture and Design: Design throttling mechanisms into the system architecture. The best protection is to limit the amount of resources that an unauthorized user can cause to be expended. A strong authentication and access control model will help prevent such attacks from occurring in the first place. The login application should be protected against DoS attacks as much as possible. Limiting the database access, perhaps by caching result sets, can help minimize the resources expended. To further limit the potential for a DoS attack, consider tracking the rate of requests received from users and blocking requests that exceed a defined rate threshold.
  • Architecture and Design: Mitigation of resource exhaustion attacks requires that the target system either: recognizes the attack and denies that user further access for a given amount of time, or uniformly throttles all requests in order to make it more difficult to consume resources more quickly than they can again be freed. The first of these solutions is an issue in itself though, since it may allow attackers to prevent the use of the system by a particular valid user. If the attacker impersonates the valid user, they may be able to prevent the user from accessing the server in question. The second solution is simply difficult to effectively institute -- and even when properly done, it does not provide a full solution. It simply makes the attack require more resources on the part of the attacker.
  • Architecture and Design: Ensure that protocols have specific limits of scale placed on them.
  • Implementation: Ensure that all failures in resource allocation place the system into a safe posture.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-228f-g3h7-3fj3
RubyGems HTTPS to HTTP redirect
Medium Also affects rubygems-update
GHSA-5mgj-mvv8-46mw
RubyGems does not verify SSL certificate
Medium Also affects rubygems-update
GHSA-qv62-xfj6-32xm
RubyGems Improper Input Validation vulnerability
Medium Also affects rubygems-update
GHSA-9qvm-2vhf-q649
RubyGems Regular Expression Denial of Service
Medium Also affects rubygems-update
GHSA-8qxg-mff5-j3wc
RubyGems Path Traversal vulnerability
Medium Also affects rubygems-update
GHSA-wp3j-rvfp-624h
RubyGems vulnerable to DNS hijack attack
High Also affects rubygems-update
GHSA-p7f2-rr42-m9xm
RubyGems Improper Input Validation vulnerability
High Also affects rubygems-update
GHSA-qj2w-mw2r-pv39
RubyGems Deserialization of Untrusted Data vulnerability
High Also affects rubygems-update
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor