org.jruby:jruby-stdlib (Maven)
Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 9.1.16.0 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.jruby</groupId><artifactId>jruby-stdlib</artifactId><version>9.1.16.0</version></dependency>gradle
implementation("org.jruby:jruby-stdlib:9.1.16.0")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability |
Medium EPSS 2.78% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-qj2w-mw2r-pv39 RubyGems Deserialization of Untrusted Data vulnerability |
High EPSS 2.88% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-mc6j-h948-v2p6 RubyGems Improper Verification of Cryptographic Signature vulnerability |
Critical EPSS 2.93% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-gv86-43rv-79m2 RubyGems Improper Input Validation vulnerability |
Medium EPSS 3.60% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-87qx-g5wg-mwmj RubyGems Cross-site Scripting vulnerability |
Medium EPSS 2.75% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-74pv-v9gh-h25p RubyGems Infinite Loop vulnerability |
High EPSS 4.74% |
< 9.1.16.0 | 9.1.16.0 |
| GHSA-gx69-6cp4-hxrj RubyGems Link Following vulnerability |
High EPSS 4.91% |
< 9.1.16.0 | 9.1.16.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor