GHSA-5mgj-mvv8-46mw CVE-2012-2126
RubyGems does not verify SSL certificate
Medium
RubyGems
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 1.36%
- Chance of exploitation in the next 30 days. Higher than 71.78% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
1.8.23- Upgrade rubygems-update to this version or later
Description
RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rubygems-update | < 1.8.23 |
1.8.23 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
rubygems-update RubyGems → 1.8.23
- bundler
bundle update rubygems-update # Gemfile: gem "rubygems-update", ">= 1.8.23"
References
Advisories
Packages
Other links
- github.com/rubygems/rubygems/commit/d4c7eafb8efe1e13a7abf5be5a5b4548870b15b7
- bugzilla.redhat.com/show_bug.cgi
- github.com/rubygems/rubygems/blob/1.8/History.txt
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2012-2…
- rhn.redhat.com/errata/RHSA-2013-1203.html
- rhn.redhat.com/errata/RHSA-2013-1441.html
- rhn.redhat.com/errata/RHSA-2013-1852.html
- openwall.com/lists/oss-security/2012/04/20/24
- ubuntu.com/usn/USN-1582-1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-228f-g3h7-3fj3 RubyGems HTTPS to HTTP redirect | Medium | Also affects rubygems-update |
| GHSA-qv62-xfj6-32xm RubyGems Improper Input Validation vulnerability | Medium | Also affects rubygems-update |
| GHSA-9qvm-2vhf-q649 RubyGems Regular Expression Denial of Service | Medium | Also affects rubygems-update |
| GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability | Medium | Also affects rubygems-update |
| GHSA-wp3j-rvfp-624h RubyGems vulnerable to DNS hijack attack | High | Also affects rubygems-update |
| GHSA-9j7m-rjqx-48vh RubyGems Regular Expression Denial of Service vulnerability | Medium | Also affects rubygems-update |
| GHSA-p7f2-rr42-m9xm RubyGems Improper Input Validation vulnerability | High | Also affects rubygems-update |
| GHSA-qj2w-mw2r-pv39 RubyGems Deserialization of Untrusted Data vulnerability | High | Also affects rubygems-update |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor