GHSA-92v7-pq4h-58j5 CVE-2014-3248
facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.54%
- Chance of exploitation in the next 30 days. Higher than 45.56% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
- Available
- 4 packages have a fixed version
Description
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| facter | < 1.7.6 |
1.7.6 |
| facter | >= 2.0.0, < 2.0.2 |
2.0.2 |
| hiera | < 1.3.4 |
1.3.4 |
| mcollective-client | < 2.5.2 |
2.5.2 |
| puppet | < 2.7.26 |
2.7.26 |
| puppet | >= 3.0.0, < 3.6.2 |
3.6.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
facter RubyGems → 1.7.6
- bundler
bundle update facter # Gemfile: gem "facter", ">= 1.7.6"
hiera RubyGems → 1.3.4
- bundler
bundle update hiera # Gemfile: gem "hiera", ">= 1.3.4"
mcollective-client RubyGems → 2.5.2
- bundler
bundle update mcollective-client # Gemfile: gem "mcollective-client", ">= 2.5.2"
puppet RubyGems → 2.7.26
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.7.26"
References
Advisories
Other links
- github.com/rubysec/ruby-advisory-db/blob/master/gems/facter/CVE-2014-3248.yml
- github.com/rubysec/ruby-advisory-db/blob/master/gems/hiera/CVE-2014-3248.yml
- github.com/rubysec/ruby-advisory-db/blob/master/gems/mcollective-client/CVE-201…
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2014-3248.yml
- web.archive.org/web/20141129061319/http://www.securityfocus.com/bid/68035
- web.archive.org/web/20150204183209/http://rowediness.com/2014/06/13/cve-2014-3248-a-…
- web.archive.org/web/20150907182402/http://puppetlabs.com/security/cve/cve-2014-3248
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mpmx-gm5v-q789 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-9pvx-fwwh-w289 Puppet does not properly restrict access to node resources | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor