GHSA-8jxj-9r5f-w3m2 CVE-2012-3866
Puppet allows local users to obtain sensitive configuration information
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.48%
- Chance of exploitation in the next 30 days. Higher than 41.49% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
2.7.18- Upgrade puppet to this version or later
Description
lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| puppet | >= 2.7.0, < 2.7.18 |
2.7.18 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
puppet RubyGems → 2.7.18
- bundler
bundle update puppet # Gemfile: gem "puppet", ">= 2.7.18"
References
Advisories
Packages
Other links
- github.com/puppetlabs/puppet/commit/fd44bf5e6d0d360f6a493d663b653c121fa83c3f
- bugzilla.redhat.com/show_bug.cgi
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-3866.yml
- puppet.com/security/cve/cve-2012-3866-lastrunreportyaml-world-readable
- lists.opensuse.org/opensuse-updates/2012-07/msg00036.html
- puppetlabs.com/security/cve/cve-2012-3866
- debian.org/security/2012/dsa-2511
- ubuntu.com/usn/USN-1506-1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mpmx-gm5v-q789 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-9pvx-fwwh-w289 Puppet does not properly restrict access to node resources | Medium | Also affects puppet |
| GHSA-qh3g-27jf-3j54 Puppet allows local users to modify the permissions of arbitrary files | Medium | Also affects puppet |
| GHSA-8c56-v25w-f89c Puppet arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-v58w-6xc2-w799 Puppet Denial of Service and Arbitrary File Write | Low | Also affects puppet |
| GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite | Medium | Also affects puppet |
| GHSA-6xxq-j39w-g3f6 Puppet Arbitrary Command Execution | Medium | Also affects puppet |
| GHSA-77hg-g8cc-5r37 Puppet Privilege Escallation | Medium | Also affects puppet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor