GHSA-74pv-v9gh-h25p CVE-2018-1000075
RubyGems Infinite Loop vulnerability
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 4.74%
- Chance of exploitation in the next 30 days. Higher than 91.86% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-835 Loop with Unreachable Exit Condition ('Infinite Loop')
- Fix
- Available
- 2 packages have a fixed version
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.jruby:jruby-stdlib | < 9.1.16.0 |
9.1.16.0 |
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rubygems-update | < 2.7.6 |
2.7.6 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.jruby:jruby-stdlib Maven → 9.1.16.0
- maven
<dependency><groupId>org.jruby</groupId><artifactId>jruby-stdlib</artifactId><version>9.1.16.0</version></dependency>- gradle
implementation("org.jruby:jruby-stdlib:9.1.16.0")
rubygems-update RubyGems → 2.7.6
- bundler
bundle update rubygems-update # Gemfile: gem "rubygems-update", ">= 2.7.6"
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-835: Loop with Unreachable Exit Condition ('Infinite Loop')
The product contains an iteration or loop with an exit condition that cannot be reached, i.e., an infinite loop.
References
Advisories
Other links
- github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183
- github.com/rubygems/rubygems/commit/92e98bf8f810bd812f919120d4832df51bc25d83
- debian.org/security/2018/dsa-4259
- debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1
- lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- lists.debian.org/debian-lts-announce/2018/04/msg00000.html
- access.redhat.com/errata/RHSA-2020:0663
- access.redhat.com/errata/RHSA-2020:0591
- access.redhat.com/errata/RHSA-2020:0542
- access.redhat.com/errata/RHSA-2019:2028
- access.redhat.com/errata/RHSA-2018:3731
- access.redhat.com/errata/RHSA-2018:3730
- access.redhat.com/errata/RHSA-2018:3729
- blog.rubygems.org/2018/02/15/2.7.6-released.html
- lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-228f-g3h7-3fj3 RubyGems HTTPS to HTTP redirect | Medium | Also affects rubygems-update |
| GHSA-5mgj-mvv8-46mw RubyGems does not verify SSL certificate | Medium | Also affects rubygems-update |
| GHSA-qv62-xfj6-32xm RubyGems Improper Input Validation vulnerability | Medium | Also affects rubygems-update |
| GHSA-9qvm-2vhf-q649 RubyGems Regular Expression Denial of Service | Medium | Also affects rubygems-update |
| GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability | Medium | Also affects org.jruby:jruby-stdlib |
| GHSA-wp3j-rvfp-624h RubyGems vulnerable to DNS hijack attack | High | Also affects rubygems-update |
| GHSA-9j7m-rjqx-48vh RubyGems Regular Expression Denial of Service vulnerability | Medium | Also affects rubygems-update |
| GHSA-p7f2-rr42-m9xm RubyGems Improper Input Validation vulnerability | High | Also affects rubygems-update |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor