@haxtheweb/haxcms-nodejs (npm)
Advisories
16
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 26.0.1 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install @haxtheweb/haxcms-nodejs@26.0.1yarn
yarn add @haxtheweb/haxcms-nodejs@26.0.1pnpm
pnpm add @haxtheweb/haxcms-nodejs@26.0.1Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-g2g8-95qg-v35h HaxCMS has a stored Cross-Site Scripting (XSS) bypass in its saveNode endpoint |
High EPSS 0.23% |
< 26.0.1 | 26.0.1 |
| GHSA-9r33-xhw8-4qqp HAX CMS: Denial of Service using Malicious Import Request |
Medium EPSS 0.24% |
< 26.0.0 | 26.0.0 |
| GHSA-x3x5-7h4h-gwxg HAXcms: Mass Token Exfiltration and Cross-Tenant Hijack |
High EPSS 0.27% |
< 26.0.0 | 26.0.0 |
| GHSA-jh3h-rpxg-fr36 Stored XSS via <iframe> in HAX CMS allows access to sensitive client-side data and account takeover |
High EPSS 0.23% |
< 26.0.0 | 26.0.0 |
| GHSA-6c8g-9hfh-pq5h HAXcms: Private Key Disclosure via Broken HMAC Implementation |
Critical EPSS 0.29% |
< 26.0.0 | 26.0.0 |
| GHSA-2m6p-hm3w-6jm3 HAX CMS: Stored XSS via '<video-player>' component allows arbitrary JavaScript execution and token theft |
Medium EPSS 0.23% |
< 26.0.0 | 26.0.0 |
| GHSA-q862-gcgq-5m6g HAXcms createSite SSRF Enables Arbitrary File Read |
High EPSS 0.24% |
< 26.0.0 | 26.0.0 |
| GHSA-3fm2-xfq7-7778 HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover |
Medium EPSS 1.03% |
>= 11.0.6, < 25.0.0 | 25.0.0 |
| GHSA-9jr9-8ff3-m894 HAX CMS API Lacks Authorization Checks |
High EPSS 0.57% |
< 11.0.14 | 11.0.14 |
| GHSA-54vw-f4xf-f92j HAX CMS application pages vulnerable to clickjacking |
Medium EPSS 0.36% |
< 11.0.13 | 11.0.13 |
| GHSA-5fpv-5qvh-7cf3 NodeJS version of the HAX CMS application is distributed with Default Secrets |
High EPSS 0.39% |
< 11.0.10 | 11.0.10 |
| GHSA-pjj3-j5j6-qj27 HAX CMS NodeJS Application Has Improper Error Handling That Leads to Denial of Service |
Medium EPSS 0.47% |
< 11.0.9 | 11.0.9 |
| GHSA-59g8-h59f-8hjp NodeJS version of HAX CMS Has Disabled Content Security Policy That Enables Cross-Site Scripting |
Medium EPSS 0.23% |
< 11.0.8 | 11.0.8 |
| GHSA-f38f-jvqj-mfg6 NodeJS version of HAX CMS Has Insecure Default Configuration That Leads to Unauthenticated Access |
Critical EPSS 0.46% |
< 11.0.7 | 11.0.7 |
| GHSA-g4cf-pp4x-hqgw HaxCMS-PHP Command Injection Vulnerability |
High EPSS 1.49% |
< 11.0.3 | 11.0.3 |
| GHSA-v3ph-2q5q-cg88 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability |
Medium EPSS 0.37% |
< 11.0.0 | 11.0.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor