org.apache.solr:solr-core (Maven)
Advisories
52
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 9.10.1 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.solr</groupId><artifactId>solr-core</artifactId><version>9.10.1</version></dependency>gradle
implementation("org.apache.solr:solr-core:9.10.1")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-qhr7-h655-pw6r Apache Solr has hardcoded credentials in the Basic Authentication setup tool |
Critical EPSS 3.92% |
No fix yet | |
| GHSA-qhr7-h655-pw6r Apache Solr has hardcoded credentials in the Basic Authentication setup tool |
Critical EPSS 3.92% |
>= 9.4.0, <= 9.10.1 | No fix yet |
| GHSA-vc2w-4v3p-2mqw Apache Solr: Insufficient file-access checking in standalone core-creation requests |
High EPSS 0.69% |
>= 8.6.0, < 9.10.1 | 9.10.1 |
| GHSA-qr3p-2xj2-q7hq Apache Solr: Unauthorized bypass of certain "predefined permission" rules in the RuleBasedAuthorizationPlugin |
High EPSS 0.58% |
>= 5.3.0, < 9.10.1 | 9.10.1 |
| GHSA-68r2-fwcg-qpm8 Apache Solr vulnerable to Execution with Unnecessary Privileges |
Medium EPSS 1.17% |
< 9.8.0 | 9.8.0 |
| GHSA-4p5m-gvpf-f3x5 Apache Solr Relative Path Traversal vulnerability |
Medium EPSS 40.92% |
>= 6.6, < 9.8.0 | 9.8.0 |
| GHSA-37vr-vmg4-jwpw Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets |
High EPSS 83.72% |
>= 9.0.0, < 9.4.1 | 9.4.1 |
| GHSA-37vr-vmg4-jwpw Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets |
High EPSS 83.72% |
>= 6.0.0, < 8.11.3 | 8.11.3 |
| GHSA-4wxw-42wx-2wfx Apache Solr Schema Designer blindly "trusts" all configsets |
High EPSS 3.02% |
>= 9.0.0, < 9.3.0 | 9.3.0 |
| GHSA-4wxw-42wx-2wfx Apache Solr Schema Designer blindly "trusts" all configsets |
High EPSS 3.02% |
>= 8.10.0, < 8.11.3 | 8.11.3 |
| GHSA-3hwc-rqwp-v36q Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies |
High EPSS 3.28% |
>= 9.0.0, < 9.3.0 | 9.3.0 |
| GHSA-3hwc-rqwp-v36q Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies |
High EPSS 3.28% |
>= 6.0.0, < 8.11.3 | 8.11.3 |
| GHSA-gg7w-pw2r-x2cq Apache Solr allows read access to host environmet variables |
Medium EPSS 68.45% |
>= 9.0.0, < 9.3.0 | 9.3.0 |
| GHSA-jq2w-w7v2-69q5 Apache Solr vulnerable to XML Bomb |
High EPSS 8.55% |
< 5.0.0 | 5.0.0 |
| GHSA-6cpj-3g83-q2j4 Improper Restriction of XML External Entity Reference in Apache Solr |
High EPSS 10.08% |
< 4.1.0 | 4.1.0 |
| GHSA-998j-j6v9-5846 Apache Solr UpdateRequestHandler for XML resolves XML External Entities |
Medium EPSS 11.40% |
< 4.1.0 | 4.1.0 |
| GHSA-45w3-2hvv-pfxq XML Injection in Apache Solr |
Medium EPSS 11.40% |
< 4.3.1 | 4.3.1 |
| GHSA-j8qw-mwmv-28cg Improper Limitation of a Pathname to a Restricted Directory in Apache Solr |
Medium EPSS 56.53% |
< 4.6.0 | 4.6.0 |
| GHSA-mx2h-hf7j-2x3p Improper Neutralization of Input During Web Page Generation in Apache Solr |
Medium EPSS 2.69% |
< 5.1.0 | 5.1.0 |
| GHSA-v6gf-x8fp-532v Improper Neutralization of Input During Web Page Generation in Apache Solr |
Medium EPSS 3.29% |
< 5.3.1 | 5.3.1 |
| GHSA-c82r-qg3w-q5mv Apache Solr insecure inter-node communication |
High EPSS 5.63% |
>= 5.3.0, < 5.5.5 | 5.5.5 |
| GHSA-c82r-qg3w-q5mv Apache Solr insecure inter-node communication |
High EPSS 5.63% |
>= 6.0.0, < 6.6.0 | 6.6.0 |
| GHSA-f553-j2gv-g5r9 Apache Solr Kerberos delegation token functionality flaws |
High EPSS 2.19% |
>= 6.2.0, < 6.6.1 | 6.6.1 |
| GHSA-3c7p-vv5r-cmr5 Incorrect Authorization in Apache Solr |
Critical EPSS 79.34% |
>= 6.6.0, < 8.6.3 | 8.6.3 |
| GHSA-j346-h5wc-rw2m Incorrect Authorization in Apache Solr |
Medium EPSS 2.02% |
>= 7.0.0, < 7.7.0 | 7.7.0 |
| GHSA-j346-h5wc-rw2m Incorrect Authorization in Apache Solr |
Medium EPSS 2.02% |
< 6.6.6 | 6.6.6 |
| GHSA-jgcr-fg3g-qvw8 Improper permission handling in Apache Solr |
High EPSS 6.72% |
< 8.8.2 | 8.8.2 |
| GHSA-2289-pqfq-6wx7 Unrestricted upload of file with dangerous type in Apache Solr |
Critical EPSS 21.61% |
>= 8.1.1, < 8.3.0 | 8.3.0 |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 8.0.0, < 8.4.0 | 8.4.0 |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 5.0.0, < 8.4.0 | 8.4.0 |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 6.0.0, < 8.4.0 | 8.4.0 |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 5.0.0, <= 5.5.5 | No fix yet |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 7.0.0, < 8.4.0 | 8.4.0 |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 8.0.0, <= 8.3.1 | No fix yet |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 7.0.0, <= 7.7.2 | No fix yet |
| CVE-2019-17558 Improper Input Validation in Apache Solr Known exploited |
High EPSS 98.57% |
>= 6.0.0, <= 6.6.6 | No fix yet |
| CVE-2019-0193 XML External Entity (XXE) Injection in Apache Solr Known exploited |
High EPSS 83.55% |
< 8.2.0 | 8.2.0 |
| CVE-2019-0193 XML External Entity (XXE) Injection in Apache Solr Known exploited |
High EPSS 83.55% |
< 8.2.0 | 8.2.0 |
| GHSA-vrh8-27q8-fr8f Server-Side Request Forgery (SSRF) in org.apache.solr:solr-core |
High EPSS 19.44% |
>= 1.3.0, < 7.7.0 | 7.7.0 |
| GHSA-xhcq-fv7x-grr2 Critical severity vulnerability that affects org.apache.solr:solr-core |
Critical EPSS 78.23% |
>= 5.0.0, < 7.0.0 | 7.0.0 |
| GHSA-xhcq-fv7x-grr2 Critical severity vulnerability that affects org.apache.solr:solr-core |
Critical EPSS 78.23% |
>= 6.0.0, < 7.0.0 | 7.0.0 |
| GHSA-387v-84cv-9qmc Improper Limitation of a Pathname ('Path Traversal') in org.apache.solr:solr-core |
High EPSS 6.56% |
< 5.5.4 | 5.5.4 |
| GHSA-387v-84cv-9qmc Improper Limitation of a Pathname ('Path Traversal') in org.apache.solr:solr-core |
High EPSS 6.56% |
>= 6.0.0, < 6.4.1 | 6.4.1 |
| GHSA-mh7g-99w9-xpjm Remote code execution occurs in Apache Solr |
Critical EPSS 91.90% |
>= 6.0.0, < 6.6.2 | 6.6.2 |
| GHSA-mh7g-99w9-xpjm Remote code execution occurs in Apache Solr |
Critical EPSS 91.90% |
>= 7.0.0, < 7.1.0 | 7.1.0 |
| GHSA-mh7g-99w9-xpjm Remote code execution occurs in Apache Solr |
Critical EPSS 91.90% |
>= 5.5.0, < 5.5.5 | 5.5.5 |
| GHSA-rc9v-h28f-jcmf There is a XML external entity expansion (XXE) vulnerability in Apache Solr config files |
Medium EPSS 3.71% |
>= 7.0.0, < 7.3.1 | 7.3.1 |
| GHSA-rc9v-h28f-jcmf There is a XML external entity expansion (XXE) vulnerability in Apache Solr config files |
Medium EPSS 3.71% |
>= 6.6.0, < 6.6.4 | 6.6.4 |
| GHSA-3pph-2595-cgfh There is a XML external entity expansion (XXE) vulnerability in Apache Solr |
High EPSS 20.82% |
>= 1.2, < 6.6.3 | 6.6.3 |
| GHSA-3pph-2595-cgfh There is a XML external entity expansion (XXE) vulnerability in Apache Solr |
High EPSS 20.82% |
>= 7.0.0, < 7.3.0 | 7.3.0 |
| GHSA-7px3-6f6g-hxcj XML external entity expansion in org.apache.solr:solr-core |
Medium EPSS 9.03% |
>= 6.0.0, < 6.6.5 | 6.6.5 |
| GHSA-7px3-6f6g-hxcj XML external entity expansion in org.apache.solr:solr-core |
Medium EPSS 9.03% |
>= 7.0.0, < 7.4.0 | 7.4.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor