org.apache.nifi:nifi (Maven)
Advisories
26
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.16.3 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.nifi</groupId><artifactId>nifi</artifactId><version>1.16.3</version></dependency>gradle
implementation("org.apache.nifi:nifi:1.16.3")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-77hf-23pq-2g7c Code injection in Apache NiFi and NiFi Registry |
High EPSS 3.74% |
>= 1.10.0, < 1.16.3 | 1.16.3 |
| GHSA-jvx9-rj3w-jq99 Origin Validation Error in Apache NiFi |
High EPSS 1.43% |
>= 1.0.0, < 1.3.0 | 1.3.0 |
| GHSA-jvx9-rj3w-jq99 Origin Validation Error in Apache NiFi |
High EPSS 1.43% |
< 0.7.4 | 0.7.4 |
| GHSA-m5r7-w9v3-ghmx Cross-site Scripting in Apache NiFi |
Medium EPSS 3.51% |
>= 1.0.0, < 1.3.0 | 1.3.0 |
| GHSA-m5r7-w9v3-ghmx Cross-site Scripting in Apache NiFi |
Medium EPSS 3.51% |
< 0.7.4 | 0.7.4 |
| GHSA-qj7f-j6h9-g5rq XML External Entity Reference in Apache NiFi |
Medium EPSS 1.94% |
>= 1.0.0, < 1.4.0 | 1.4.0 |
| GHSA-jrcc-7jf5-3pxg Injection in Apache NiFi |
Critical EPSS 3.60% |
< 0.7.2 | 0.7.2 |
| GHSA-jrcc-7jf5-3pxg Injection in Apache NiFi |
Critical EPSS 3.60% |
>= 1.0.0, < 1.1.2 | 1.1.2 |
| GHSA-29ph-fjf3-c5cm Apache NiFi XSS issue in context path handling |
Critical EPSS 4.83% |
>= 1.0.0, < 1.5.0 | 1.5.0 |
| GHSA-w4x6-j349-9r57 Apache NiFi host header poisoning issue |
High EPSS 2.85% |
>= 1.0.0, < 1.5.0 | 1.5.0 |
| GHSA-p76j-5v6v-6c22 Apache NiFi JMS Deserialization issue |
High EPSS 3.18% |
< 1.6.0 | 1.6.0 |
| GHSA-g2fm-x3cp-mqw9 Cross-site Scripting in Apache NiFi |
Medium EPSS 1.99% |
>= 1.1.0, < 1.1.1 | 1.1.1 |
| GHSA-g2fm-x3cp-mqw9 Cross-site Scripting in Apache NiFi |
Medium EPSS 1.99% |
< 1.0.1 | 1.0.1 |
| GHSA-jgj9-6v78-6g8m Improper Authentication In Apache NiFi |
High EPSS 3.29% |
>= 1.0.0, < 1.1.2 | 1.1.2 |
| GHSA-jgj9-6v78-6g8m Improper Authentication In Apache NiFi |
High EPSS 3.29% |
< 0.7.2 | 0.7.2 |
| GHSA-wc97-7623-rxwx Multiple components in Apache NiFi do not restrict XML External Entity references |
High EPSS 2.60% |
>= 0.0.1, < 1.16.1 | 1.16.1 |
| GHSA-rfmp-jvr7-hx78 Inadequate Encryption Strength in Apache NiFi |
High EPSS 2.87% |
>= 1.2.0, < 1.12.0-RC1 | 1.12.0-RC1 |
| GHSA-3pp3-77j6-8ph6 Missing Authentication for Critical Function in Apache NiFi |
High EPSS 3.05% |
>= 1.0.0, < 1.12.0-RC1 | 1.12.0-RC1 |
| GHSA-q4xf-3pmq-3hw8 Improper Restriction of XML External Entity Reference in Apache NiFi |
Medium EPSS 1.91% |
>= 1.0.0, < 1.12.0-RC1 | 1.12.0-RC1 |
| GHSA-pqhq-xx62-2v2p Cross-site scripting in Apache NiFi |
Medium EPSS 2.81% |
>= 1.0.0, < 1.11.0 | 1.11.0 |
| GHSA-rq96-qhc5-vm4r Exposure of Sensitive Information to an Unauthorized Actor in Apache NiFi |
Medium EPSS 1.76% |
< 1.15.1 | 1.15.1 |
| GHSA-26p8-xrj2-mv53 Apache NiFi process group information disclosure |
Medium EPSS 2.75% |
>= 1.3.0, < 1.10.0 | 1.10.0 |
| GHSA-744r-vv2g-2x6g Apache NiFi information disclosure by XXE |
Medium EPSS 2.26% |
>= 1.3.0, < 1.10.0 | 1.10.0 |
| GHSA-3jq8-jg75-rqv6 Cleartext Transmission of Sensitive Information in Apache nifi |
High EPSS 0.71% |
>= 1.0.0, < 1.8.0 | 1.8.0 |
| GHSA-4qq9-rrq6-48ff Cross site scripting in org.apache.nifi:nifi |
Medium EPSS 2.76% |
>= 1.0.0, < 1.8.0 | 1.8.0 |
| GHSA-2xpp-75vr-22vq Improper Restriction of Rendered UI Layers or Frames in Apache nifif |
Medium EPSS 2.68% |
>= 1.0.0, < 1.8.0 | 1.8.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor