Skip to content

org.apache.jspwiki:jspwiki-main (Maven)

Advisories
18
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.12.3 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.apache.jspwiki</groupId><artifactId>jspwiki-main</artifactId><version>2.12.3</version></dependency>
gradle
implementation("org.apache.jspwiki:jspwiki-main:2.12.3")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-72ww-4rcw-mc62
Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin
Medium
EPSS 0.47%
< 2.12.3
2.12.3
GHSA-rrff-chj9-w4c7
Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering
High
EPSS 0.56%
< 2.12.3
2.12.3
GHSA-36gf-vpj2-j42w
Cross site scripting in Apache JSPWiki
Medium
EPSS 60.85%
< 2.12.2
2.12.2
GHSA-qvq8-cw7f-m7m4
Apache JSPWiki vulnerable to cross-site scripting on several plugins
Medium
EPSS 1.16%
< 2.12.0
2.12.0
GHSA-2fxf-qj94-3f83
Apache JSPWiki XSS due to crafted request on XHRHtml2Markup.jsp
Medium
EPSS 86.16%
< 2.11.3
2.11.3
GHSA-jp3m-p26h-mm7v
Apache JSPWiki CSRF due to crafted invocation on the Image plugin
High
EPSS 1.28%
< 2.11.3
2.11.3
GHSA-9x9j-vrhj-v364
Apache JSPWiki CSRF due to crafted request on UserPreferences.jsp
Medium
EPSS 58.72%
< 2.11.3
2.11.3
GHSA-ggjq-8c4c-68r5
Apache JSPWiki XSS due to incomplete patch for CVE-2021-40369
Medium
EPSS 86.16%
< 2.11.3
2.11.3
GHSA-hph8-29xw-qfxx
Apache JSPWiki XSS due to crafted request in WeblogPlugin
Medium
EPSS 82.83%
< 2.11.3
2.11.3
GHSA-p2r4-rpj8-m2p9
Cross-site Scripting in Apache JSPWiki
Medium
EPSS 2.91%
< 2.11.0.M5
2.11.0.M5
GHSA-4284-x26r-4hhc
Cross Site Request Forgery in Apache JSPWiki
High
EPSS 1.16%
< 2.11.2
2.11.2
GHSA-9953-fmrw-v4vm
Cross-site Scripting in Apache JSPWiki
Medium
EPSS 2.25%
< 2.11.2
2.11.2
GHSA-cfqj-9g2g-w7q6
Apache JSPWiki Cross-site Scripting due to carefully crafted plugin link invocation
Medium
EPSS 3.42%
< 2.11.0
2.11.0
GHSA-8gw6-w5rw-4g5c
Incorrect Default Permissions in Apache JSPWiki
Critical
EPSS 6.36%
< 2.11.0
2.11.0
GHSA-hp5r-mhgp-56c9
Cross-site Scriptin in JSPWiki
Medium
EPSS 4.94%
>= 2.9.0, < 2.11.0.M4
2.11.0.M4
GHSA-cj6j-32rg-45r2
Cross-site Scripting in JSPWiki
Medium
EPSS 4.68%
>= 2.9.0, < 2.11.0.M4
2.11.0.M4
GHSA-cxx2-fp39-rf3r
Cross-Site Scripting in JSPWiki
Medium
EPSS 4.72%
>= 2.9.0, < 2.11.0.M4
2.11.0.M4
GHSA-fmpq-w5q6-9vf9
Moderate severity vulnerability that affects org.apache.jspwiki:jspwiki-main
Medium
EPSS 5.15%
>= 2.9.0, < 2.11.0.M3
2.11.0.M3
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor