GHSA-4284-x26r-4hhc CVE-2022-24947
Cross Site Request Forgery in Apache JSPWiki
- Severity
- 8.8 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.16%
- Chance of exploitation in the next 30 days. Higher than 67.14% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-352 Cross-Site Request Forgery (CSRF)
- Fix
2.11.2- Upgrade org.apache.jspwiki:jspwiki-main to this version or later
Description
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.jspwiki:jspwiki-main | < 2.11.2 |
2.11.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.jspwiki:jspwiki-main Maven → 2.11.2
- maven
<dependency><groupId>org.apache.jspwiki</groupId><artifactId>jspwiki-main</artifactId><version>2.11.2</version></dependency>- gradle
implementation("org.apache.jspwiki:jspwiki-main:2.11.2")
Severity breakdown
CVSS 3.1 8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-352: Cross-Site Request Forgery (CSRF)
The web application does not, or cannot, sufficiently verify whether a request was intentionally provided by the user who sent the request, which could have originated from an unauthorized actor.
How to prevent it
- Architecture and Design: Use a vetted library or framework that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid [REF-1482]. For example, use anti-CSRF packages such as the OWASP CSRFGuard. [REF-330] Another example is the ESAPI Session Management control, which includes a component for CSRF. [REF-45]
- Implementation: Ensure that the application is free of cross-site scripting issues (CWE-79), because most CSRF defenses can be bypassed using attacker-controlled script.
- Architecture and Design: Generate a unique nonce for each form, place the nonce into the form, and verify the nonce upon receipt of the form. Be sure that the nonce is not predictable (CWE-330). [REF-332]
- Architecture and Design: Identify especially dangerous operations. When the user performs a dangerous operation, send a separate confirmation request to ensure that the user intended to perform that operation.
- Architecture and Design: Use the "double-submitted cookie" method as described by Felten and Zeller: When a user visits a site, the site should generate a pseudorandom value and set it as a cookie on the user's machine. The site should require every form submission to include this value as a form value and also as a cookie value. When a POST request is sent to the site, the request should only be considered valid if the form value and the cookie value are the same. Because of the same-origin policy, an attacker cannot read or modify the value stored in the cookie. To successfully submit a form on behalf of the user, the attacker would have to correctly guess the pseudorandom value. If the pseudorandom value is cryptographically strong, this will be prohibitively difficult. This technique requires Javascript, so it may not work for browsers that have Javascript disabled. [REF-331]
- Architecture and Design: Do not use the GET method for any request that triggers a state change.
- Implementation: Check the HTTP Referer header to see if the request originated from an expected page. This could break legitimate functionality, because users or proxies may have disabled sending the Referer for privacy reasons.
References
Advisories
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-72ww-4rcw-mc62 Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin | Medium | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-rrff-chj9-w4c7 Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering | High | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-36gf-vpj2-j42w Cross site scripting in Apache JSPWiki | Medium | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-qvq8-cw7f-m7m4 Apache JSPWiki vulnerable to cross-site scripting on several plugins | Medium | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-jp3m-p26h-mm7v Apache JSPWiki CSRF due to crafted invocation on the Image plugin | High | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-2fxf-qj94-3f83 Apache JSPWiki XSS due to crafted request on XHRHtml2Markup.jsp | Medium | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-hph8-29xw-qfxx Apache JSPWiki XSS due to crafted request in WeblogPlugin | Medium | Also affects org.apache.jspwiki:jspwiki-main |
| GHSA-ggjq-8c4c-68r5 Apache JSPWiki XSS due to incomplete patch for CVE-2021-40369 | Medium | Also affects org.apache.jspwiki:jspwiki-main |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor