Skip to content

GHSA-8gw6-w5rw-4g5c CVE-2021-44140

Incorrect Default Permissions in Apache JSPWiki

Critical Maven
Severity
9.1 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
6.36%
Chance of exploitation in the next 30 days. Higher than 93.65% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-276 Incorrect Default Permissions
Fix
2.11.0
Upgrade org.apache.jspwiki:jspwiki-main to this version or later

Description

Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.jspwiki:jspwiki-main
< 2.11.0
2.11.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.jspwiki:jspwiki-main Maven → 2.11.0

maven
<dependency><groupId>org.apache.jspwiki</groupId><artifactId>jspwiki-main</artifactId><version>2.11.0</version></dependency>
gradle
implementation("org.apache.jspwiki:jspwiki-main:2.11.0")

Severity breakdown

CVSS 3.1 9.1

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
High

Weakness

CWE-276: Incorrect Default Permissions

During installation, installed file permissions are set to allow anyone to modify those files.

How to prevent it
  • Architecture and Design, Operation: The architecture needs to access and modification attributes for files to only those users who actually require those actions.
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-72ww-4rcw-mc62
Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin
Medium Also affects org.apache.jspwiki:jspwiki-main
GHSA-rrff-chj9-w4c7
Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering
High Also affects org.apache.jspwiki:jspwiki-main
GHSA-36gf-vpj2-j42w
Cross site scripting in Apache JSPWiki
Medium Also affects org.apache.jspwiki:jspwiki-main
GHSA-qvq8-cw7f-m7m4
Apache JSPWiki vulnerable to cross-site scripting on several plugins
Medium Also affects org.apache.jspwiki:jspwiki-main
GHSA-jp3m-p26h-mm7v
Apache JSPWiki CSRF due to crafted invocation on the Image plugin
High Also affects org.apache.jspwiki:jspwiki-main
GHSA-2fxf-qj94-3f83
Apache JSPWiki XSS due to crafted request on XHRHtml2Markup.jsp
Medium Also affects org.apache.jspwiki:jspwiki-main
GHSA-hph8-29xw-qfxx
Apache JSPWiki XSS due to crafted request in WeblogPlugin
Medium Also affects org.apache.jspwiki:jspwiki-main
GHSA-ggjq-8c4c-68r5
Apache JSPWiki XSS due to incomplete patch for CVE-2021-40369
Medium Also affects org.apache.jspwiki:jspwiki-main
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor