org.apache.inlong:manager-pojo (Maven)
Advisories
17
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.2.0 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.inlong</groupId><artifactId>manager-pojo</artifactId><version>2.2.0</version></dependency>gradle
implementation("org.apache.inlong:manager-pojo:2.2.0")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-98v7-xxxv-hcrh Apache InLong: JDBC Vulnerability for Invisible Character Bypass Leading to Arbitrary File Read |
Critical EPSS 0.86% |
>= 1.13.0, < 2.2.0 | 2.2.0 |
| GHSA-532x-j9r7-8f73 Apache InLong: JDBC Vulnerability For URLEncode and backspace bypass |
Medium EPSS 0.86% |
>= 1.13.0, < 2.2.0 | 2.2.0 |
| GHSA-r324-vgr5-73c9 Apache InLong: JDBC Vulnerability during verification processing |
Medium EPSS 0.90% |
>= 1.13.0, < 2.2.0 | 2.2.0 |
| GHSA-fgh3-pwmp-3qw3 Apache Inlong Deserialization of Untrusted Data vulnerability |
Critical EPSS 1.14% |
>= 1.7.0, < 1.12.0 | 1.12.0 |
| GHSA-crwj-2r3c-gx2g Apache InLong Manager Arbitrary File Read Vulnerability |
High EPSS 1.01% |
>= 1.5.0, < 1.10.0 | 1.10.0 |
| GHSA-9xg9-hh45-xcm6 Apache InLong Manager Remote Code Execution vulnerability |
Critical EPSS 1.62% |
>= 1.5.0, < 1.10.0 | 1.10.0 |
| GHSA-jj32-3pf5-5mv5 Apache InLong Deserialization of Untrusted Data Vulnerability |
High EPSS 1.37% |
>= 1.4.0, < 1.9.0 | 1.9.0 |
| GHSA-rp6x-ggw6-8g56 Authorization Bypass in Apache InLong |
Critical EPSS 1.43% |
>= 1.4.0, < 1.9.0 | 1.9.0 |
| GHSA-pq67-9jf9-hc3c JDBC URL bypassing by allowLoadLocalInfileInPath param |
High EPSS 1.70% |
>= 1.4.0, < 1.8.0 | 1.8.0 |
| GHSA-7mhc-76hf-3jp9 Apache InLong Exposure of Resource to Wrong Sphere vulnerability |
High EPSS 1.30% |
>= 1.4.0, < 1.7.0 | 1.7.0 |
| GHSA-h79m-5cm2-278c User data exposure in Apache InLong |
Medium EPSS 1.11% |
>= 1.5.0, < 1.7.0 | 1.7.0 |
| GHSA-w3wr-gmwf-r333 Apache InLong has Weak Password Requirements in Apache InLong |
Critical EPSS 1.23% |
>= 1.1.0, < 1.47.0 | 1.47.0 |
| GHSA-757p-7hp5-pqmr Apache InLong Insufficient Session Expiration vulnerability |
Critical EPSS 1.16% |
>= 1.4.0, < 1.7.0 | 1.7.0 |
| GHSA-q5p5-xg93-2jqc Apache InLong Improper Privilege Management vulnerability |
Critical EPSS 1.29% |
>= 1.2.0, < 1.7.0 | 1.7.0 |
| GHSA-f475-jgg3-3jwc Apache InLong Exposure of Resource to Wrong Sphere vulnerability |
High EPSS 1.25% |
>= 1.4.0, < 1.7.0 | 1.7.0 |
| GHSA-c3rh-f2w5-fghm Apache InLong Deserialization of Untrusted Data Vulnerability |
High EPSS 1.23% |
>= 1.4.0, < 1.7.0 | 1.7.0 |
| GHSA-cqr6-3x3f-9wr3 Apache InLong SQL Injection vulnerability |
Medium EPSS 1.16% |
>= 1.4.0, < 1.6.0 | 1.6.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor