GHSA-w3wr-gmwf-r333 CVE-2023-31098
Apache InLong has Weak Password Requirements in Apache InLong
- Severity
- 9.8 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 1.23%
- Chance of exploitation in the next 30 days. Higher than 69.01% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-521 Weak Password Requirements
- Fix
1.47.0- Upgrade org.apache.inlong:manager-pojo to this version or later
Description
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.1.0 through 1.6.0. When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 to solve it.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.inlong:manager-pojo | >= 1.1.0, < 1.47.0 |
1.47.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.inlong:manager-pojo Maven → 1.47.0
- maven
<dependency><groupId>org.apache.inlong</groupId><artifactId>manager-pojo</artifactId><version>1.47.0</version></dependency>- gradle
implementation("org.apache.inlong:manager-pojo:1.47.0")
Severity breakdown
CVSS 3.1 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-521: Weak Password Requirements
The product does not require that users should have strong passwords.
How to prevent it
- Architecture and Design: A product's design should require adherance to an appropriate password policy. Specific password requirements depend strongly on contextual factors, but it is recommended to contain the following attributes: Enforcement of a minimum and maximum length Restrictions against password reuse Restrictions against using common passwords Restrictions against using contextual string in the password (e.g., user id, app name) Depending on the threat model, the password policy may include several additional attributes. Complex passwords requiring mixed character sets (alpha, numeric, special, mixed case) Increasing the range of characters makes the password harder to crack and may be appropriate for systems relying on single factor authentication. Unfortunately, a complex password may be difficult to memorize, encouraging a user to select a short password or to incorrectly manage the password (write it down). Another disadvantage of this approach is that it often does not result in a significant increases in overal password complexity due to people's predictable usage of various symbols. Large Minimum Length (encouraging passphrases instead of passwords) Increasing the number of characters makes the password harder to crack and may be appropriate for systems relying on single factor authentication. A disadvantage of this approach is that selecting a good passphrase is not easy and poor passwords can still be generated. Some prompting may be needed to encourage long un-predictable passwords. Randomly Chosen Secrets Generating a password for the user can help make sure that length and complexity requirements are met, and can result in secure passwords being used. A disadvantage of this approach is that the resulting password or passpharse may be too difficult to memorize, encouraging them to be written down. See NIST 800-63B [REF-1053] for further information on password requirements.
- Architecture and Design: Consider a second authentication factor beyond the password, which prevents the password from being a single point of failure. See CWE-308 for further information.
- Implementation: Consider implementing a password complexity meter to inform users when a chosen password meets the required attributes.
- Implementation: Previously, "password expiration" was widely advocated as a defense-in-depth approach to minimize the risk of weak passwords, and it has become a common practice. Password expiration requires a password to be changed within a fixed time window (such as every 90 days). However, this approach has significant limitations in the current threat landscape, and its utility has been reduced in light of the adoption of related protection mechanisms (such as password complexity and computational effort), along with the recognition that regular password changes often caused users to generate more predictable passwords. As a result, this is now a Discouraged Common Practice [REF-1488] [REF-1489], especially as the sole factor in protecting passwords. It is still strongly encouraged to force password changes in case of evidence of compromise, but this is not the same as a forced "expiration" on an arbitrary time frame.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-98v7-xxxv-hcrh Apache InLong: JDBC Vulnerability for Invisible Character Bypass Leading to Arbitrary File Read | Critical | Also affects org.apache.inlong:manager-pojo |
| GHSA-532x-j9r7-8f73 Apache InLong: JDBC Vulnerability For URLEncode and backspace bypass | Medium | Also affects org.apache.inlong:manager-pojo |
| GHSA-r324-vgr5-73c9 Apache InLong: JDBC Vulnerability during verification processing | Medium | Also affects org.apache.inlong:manager-pojo |
| GHSA-fgh3-pwmp-3qw3 Apache Inlong Deserialization of Untrusted Data vulnerability | Critical | Also affects org.apache.inlong:manager-pojo |
| GHSA-crwj-2r3c-gx2g Apache InLong Manager Arbitrary File Read Vulnerability | High | Also affects org.apache.inlong:manager-pojo |
| GHSA-9xg9-hh45-xcm6 Apache InLong Manager Remote Code Execution vulnerability | Critical | Also affects org.apache.inlong:manager-pojo |
| GHSA-jj32-3pf5-5mv5 Apache InLong Deserialization of Untrusted Data Vulnerability | High | Also affects org.apache.inlong:manager-pojo |
| GHSA-rp6x-ggw6-8g56 Authorization Bypass in Apache InLong | Critical | Also affects org.apache.inlong:manager-pojo |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor