Skip to content

GHSA-c825-6ph3-4h84 BIT-activemq-2025-66168 CVE-2025-66168

Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound

High Maven
Severity
5.4 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.87%
Chance of exploitation in the next 30 days. Higher than 58.89% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-190 Integer Overflow or Wraparound
Fix
Available
3 packages have a fixed version

Description

Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted.

This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0

Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.activemq:activemq-all
< 5.19.2
5.19.2
org.apache.activemq:activemq-all
>= 6.0.0, < 6.1.9
6.1.9
org.apache.activemq:activemq-all
>= 6.2.0, < 6.2.1
6.2.1
org.apache.activemq:activemq-mqtt
< 5.19.2
5.19.2
org.apache.activemq:activemq-mqtt
>= 6.0.0, < 6.1.9
6.1.9
org.apache.activemq:activemq-mqtt
>= 6.2.0, < 6.2.1
6.2.1
org.apache.activemq:apache-activemq
< 5.19.2
5.19.2
org.apache.activemq:apache-activemq
>= 6.0.0, < 6.1.9
6.1.9
org.apache.activemq:apache-activemq
>= 6.2.0, < 6.2.1
6.2.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.activemq:activemq-all Maven → 5.19.2

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-all</artifactId><version>5.19.2</version></dependency>
gradle
implementation("org.apache.activemq:activemq-all:5.19.2")

org.apache.activemq:activemq-mqtt Maven → 5.19.2

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-mqtt</artifactId><version>5.19.2</version></dependency>
gradle
implementation("org.apache.activemq:activemq-mqtt:5.19.2")

org.apache.activemq:apache-activemq Maven → 5.19.2

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>apache-activemq</artifactId><version>5.19.2</version></dependency>
gradle
implementation("org.apache.activemq:apache-activemq:5.19.2")

Severity breakdown

CVSS 3.1 5.4

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

Weakness

CWE-190: Integer Overflow or Wraparound

The product performs a calculation that can produce an integer overflow or wraparound when the logic assumes that the resulting value will always be larger than the original value. This occurs when an integer value is incremented to a value that is too large to store in the associated representation. When this occurs, the value may become a very small or negative number.

How to prevent it
  • Requirements: Ensure that all protocols are strictly defined, such that all out-of-bounds behavior can be identified simply, and require strict conformance to the protocol.
  • Requirements: Use a language that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid. If possible, choose a language or compiler that performs automatic bounds checking.
  • Architecture and Design: Use a vetted library or framework that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid [REF-1482]. Use libraries or frameworks that make it easier to handle numbers without unexpected consequences. Examples include safe integer handling packages such as SafeInt (C++) or IntegerLib (C or C++). [REF-106]
  • Implementation: Perform input validation on any numeric input by ensuring that it is within the expected range. Enforce that the input meets both the minimum and maximum requirements for the expected range. Use unsigned integers where possible. This makes it easier to perform validation for integer overflows. When signed integers are required, ensure that the range check includes minimum values as well as maximum values.
  • Implementation: Understand the programming language's underlying representation and how it interacts with numeric calculation (CWE-681). Pay close attention to byte size discrepancies, precision, signed/unsigned distinctions, truncation, conversion and casting between types, "not-a-number" calculations, and how the language handles numbers that are too large or too small for its underlying representation. [REF-7] Also be careful to account for 32-bit, 64-bit, and other potential differences that may affect the numeric representation.
  • Architecture and Design: For any security checks that are performed on the client side, ensure that these checks are duplicated on the server side, in order to avoid CWE-602. Attackers can bypass the client-side checks by modifying values after the checks have been performed, or by changing the client to remove the client-side checks entirely. Then, these modified values would be submitted to the server.
  • Implementation: Examine compiler warnings closely and eliminate problems with potential security implications, such as signed / unsigned mismatch in memory operations, or use of uninitialized variables. Even if the weakness is rarely exploitable, a single failure may lead to the compromise of the entire system.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
High Known exploited Also affects org.apache.activemq:activemq-all
GHSA-hf52-78x8-6w3w
Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability
Medium Also affects org.apache.activemq:activemq-all
GHSA-99qx-5qqr-4j95
Apache ActiveMQ has an Incorrect Default Permissions vulnerability
High Also affects org.apache.activemq:apache-activemq
GHSA-cpw7-g3p5-qrfq
Apache ActiveMQ server has an incomplete authorization workflow
Medium Also affects org.apache.activemq:apache-activemq
GHSA-v853-w46p-fv2h
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High Also affects org.apache.activemq:activemq-all
GHSA-hg6c-8mvr-jqc9
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High Also affects org.apache.activemq:activemq-all
GHSA-8wm6-6fqh-phmc
Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue
Medium Also affects org.apache.activemq:apache-activemq
GHSA-mr6m-xj7v-3cv3
Apache ActiveMQ Vulnerable to Code Injection
High Also affects org.apache.activemq:activemq-all
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor