org.apache.activemq:apache-activemq (Maven)
Advisories
28
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.2.6 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>apache-activemq</artifactId><version>6.2.6</version></dependency>gradle
implementation("org.apache.activemq:apache-activemq:6.2.6")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-hf52-78x8-6w3w Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability |
Medium EPSS 0.37% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-hf52-78x8-6w3w Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability |
Medium EPSS 0.37% |
< 5.19.7 | 5.19.7 |
| GHSA-99qx-5qqr-4j95 Apache ActiveMQ has an Incorrect Default Permissions vulnerability |
High EPSS 0.44% |
< 5.19.7 | 5.19.7 |
| GHSA-99qx-5qqr-4j95 Apache ActiveMQ has an Incorrect Default Permissions vulnerability |
High EPSS 0.44% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-cpw7-g3p5-qrfq Apache ActiveMQ server has an incomplete authorization workflow |
Medium EPSS 0.35% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-cpw7-g3p5-qrfq Apache ActiveMQ server has an incomplete authorization workflow |
Medium EPSS 0.35% |
< 5.19.7 | 5.19.7 |
| GHSA-v853-w46p-fv2h Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue |
High EPSS 0.60% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-v853-w46p-fv2h Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue |
High EPSS 0.60% |
< 5.19.7 | 5.19.7 |
| GHSA-hg6c-8mvr-jqc9 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue |
High EPSS 0.74% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-hg6c-8mvr-jqc9 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue |
High EPSS 0.74% |
< 5.19.7 | 5.19.7 |
| GHSA-8wm6-6fqh-phmc Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue |
Medium EPSS 1.02% |
>= 6.0.0, < 6.2.6 | 6.2.6 |
| GHSA-8wm6-6fqh-phmc Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue |
Medium EPSS 1.02% |
< 5.19.7 | 5.19.7 |
| GHSA-mr6m-xj7v-3cv3 Apache ActiveMQ Vulnerable to Code Injection |
High EPSS 0.98% |
< 5.19.6 | 5.19.6 |
| GHSA-mr6m-xj7v-3cv3 Apache ActiveMQ Vulnerable to Code Injection |
High EPSS 0.98% |
>= 6.0.0, < 6.2.5 | 6.2.5 |
| GHSA-2jp3-2923-9h52 Apache ActiveMQ Vulnerable to Cross-site Scripting |
Medium EPSS 0.56% |
>= 6.0.0, < 6.2.5 | 6.2.5 |
| GHSA-2jp3-2923-9h52 Apache ActiveMQ Vulnerable to Cross-site Scripting |
Medium EPSS 0.56% |
< 5.19.6 | 5.19.6 |
| GHSA-w3w2-mpp5-92gm Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection |
High EPSS 4.78% |
>= 6.0.0, < 6.2.5 | 6.2.5 |
| GHSA-w3w2-mpp5-92gm Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection |
High EPSS 4.78% |
< 5.19.6 | 5.19.6 |
| GHSA-5568-6qcg-g7fx Apache ActiveMQ: Denial of Service via Out of Memory vulnerability |
High EPSS 0.90% |
< 5.19.4 | 5.19.4 |
| GHSA-5568-6qcg-g7fx Apache ActiveMQ: Denial of Service via Out of Memory vulnerability |
High EPSS 0.90% |
>= 6.0.0, < 6.2.4 | 6.2.4 |
| GHSA-xvqc-pp94-fmpx Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound |
High EPSS 0.38% |
>= 6.0.0, < 6.2.4 | 6.2.4 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
< 5.19.2 | 5.19.2 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
>= 6.0.0, < 6.1.9 | 6.1.9 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
>= 6.2.0, < 6.2.1 | 6.2.1 |
| GHSA-gj5m-m88j-v7c3 Apache ActiveMQ's default configuration doesn't secure the API web context |
High EPSS 7.15% |
>= 6.0.0, < 6.1.2 | 6.1.2 |
| GHSA-53v4-42fg-g287 Apache ActiveMQ Deserialization of Untrusted Data vulnerability |
High EPSS 85.81% |
< 5.16.6 | 5.16.6 |
| GHSA-53v4-42fg-g287 Apache ActiveMQ Deserialization of Untrusted Data vulnerability |
High EPSS 85.81% |
>= 5.17.0, < 5.17.4 | 5.17.4 |
| GHSA-34fp-xvxp-rg22 Apache ActiveMQ default configuration subject to denial of service |
Medium EPSS 7.77% |
< 5.8.0 | 5.8.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor