org.apache.activemq:activemq-mqtt (Maven)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.2.4 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-mqtt</artifactId><version>6.2.4</version></dependency>gradle
implementation("org.apache.activemq:activemq-mqtt:6.2.4")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-xvqc-pp94-fmpx Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound |
High EPSS 0.38% |
>= 6.0.0, < 6.2.4 | 6.2.4 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
< 5.19.2 | 5.19.2 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
>= 6.0.0, < 6.1.9 | 6.1.9 |
| GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound |
High EPSS 0.87% |
>= 6.2.0, < 6.2.1 | 6.2.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor