Skip to content

GHSA-hf52-78x8-6w3w BIT-activemq-2026-49270 CVE-2026-49270

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability

Medium Maven
Severity
5.9 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.37%
Chance of exploitation in the next 30 days. Higher than 30.76% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-1230 Exposure of Sensitive Information Through Metadata
Fix
Available
3 packages have a fixed version

Description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.

Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated.

This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6.

Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.activemq:activemq-all
< 5.19.7
5.19.7
org.apache.activemq:activemq-all
>= 6.0.0, < 6.2.6
6.2.6
org.apache.activemq:activemq-broker
< 5.19.7
5.19.7
org.apache.activemq:activemq-broker
>= 6.0.0, < 6.2.6
6.2.6
org.apache.activemq:apache-activemq
< 5.19.7
5.19.7
org.apache.activemq:apache-activemq
>= 6.0.0, < 6.2.6
6.2.6

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.activemq:activemq-all Maven → 5.19.7

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-all</artifactId><version>5.19.7</version></dependency>
gradle
implementation("org.apache.activemq:activemq-all:5.19.7")

org.apache.activemq:activemq-broker Maven → 5.19.7

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-broker</artifactId><version>5.19.7</version></dependency>
gradle
implementation("org.apache.activemq:activemq-broker:5.19.7")

org.apache.activemq:apache-activemq Maven → 5.19.7

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>apache-activemq</artifactId><version>5.19.7</version></dependency>
gradle
implementation("org.apache.activemq:apache-activemq:5.19.7")

Severity breakdown

CVSS 3.1 5.9

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

Weakness

CWE-1230: Exposure of Sensitive Information Through Metadata

The product prevents direct access to a resource containing sensitive information, but it does not sufficiently limit access to metadata that is derived from the original, sensitive information.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
High Known exploited Also affects org.apache.activemq:activemq-all
GHSA-99qx-5qqr-4j95
Apache ActiveMQ has an Incorrect Default Permissions vulnerability
High Also affects org.apache.activemq:apache-activemq
GHSA-cpw7-g3p5-qrfq
Apache ActiveMQ server has an incomplete authorization workflow
Medium Also affects org.apache.activemq:apache-activemq
GHSA-v853-w46p-fv2h
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High Also affects org.apache.activemq:activemq-all
GHSA-hg6c-8mvr-jqc9
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High Also affects org.apache.activemq:activemq-all
GHSA-8wm6-6fqh-phmc
Apache ActiveMQ, Apache ActiveMQ Web have a Cross-site Scripting issue
Medium Also affects org.apache.activemq:apache-activemq
GHSA-mr6m-xj7v-3cv3
Apache ActiveMQ Vulnerable to Code Injection
High Also affects org.apache.activemq:activemq-all
GHSA-2jp3-2923-9h52
Apache ActiveMQ Vulnerable to Cross-site Scripting
Medium Also affects org.apache.activemq:activemq-all
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor