Skip to content

hyper (crates.io)

Advisories
17
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 0.14.12 or later clears every advisory below that has a fix.

Upgrade commands
cargo
cargo update -p hyper --precise 0.14.12

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-f67m-9j94-qv9j
Parser creates invalid uninitialized value
High
>= 0.0.0-0, < 0.14.12
0.14.12
GHSA-f67m-9j94-qv9j
Parser creates invalid uninitialized value
High
< 0.14.12
0.14.12
GHSA-5h46-h7hh-c6x9
Integer Overflow in Chunked Transfer-Encoding
Medium
EPSS 1.16%
>= 0.0.0-0, < 0.14.10
0.14.10
GHSA-5h46-h7hh-c6x9
Integer Overflow in Chunked Transfer-Encoding
Medium
EPSS 1.16%
< 0.14.10
0.14.10
GHSA-f3pg-qwvg-p99c
Lenient Parsing of Content-Length Header When Prefixed with Plus Sign
Low
EPSS 1.13%
< 0.14.10
0.14.10
GHSA-f3pg-qwvg-p99c
Lenient Parsing of Content-Length Header When Prefixed with Plus Sign
Low
EPSS 1.13%
>= 0.0.0-0, < 0.14.10
0.14.10
GHSA-6hfq-h8hq-87mf
HTTP Request Smuggling in hyper
Medium
EPSS 4.73%
>= 0.12.0, < 0.12.36
0.12.36
GHSA-6hfq-h8hq-87mf
HTTP Request Smuggling in hyper
Medium
EPSS 4.73%
>= 0.14.0, < 0.14.3
0.14.3
GHSA-6hfq-h8hq-87mf
HTTP Request Smuggling in hyper
Medium
EPSS 4.73%
>= 0.13.0, < 0.13.10
0.13.10
GHSA-6hfq-h8hq-87mf
HTTP Request Smuggling in hyper
Medium
EPSS 4.73%
>= 0.12.0, < 0.12.36
>= 0.13.0-0, < 0.13.10
>= 0.14.0-0, < 0.14.3
0.12.36
0.13.10
0.14.3
GHSA-h3qr-rq2j-74w4
HTTP Request Smuggling in hyper
Critical
EPSS 2.97%
>= 0.11.0, < 0.12.34
0.12.34
GHSA-h3qr-rq2j-74w4
HTTP Request Smuggling in hyper
Critical
EPSS 2.97%
>= 0.11.0, < 0.12.34
0.12.34
GHSA-q89x-f52w-6hj2
Headers containing newline characters can split messages in hyper
Medium
EPSS 1.03%
>= 0.0.0-0, < 0.9.18
>= 0.10.0, < 0.10.2
0.9.18
0.10.2
GHSA-q89x-f52w-6hj2
Headers containing newline characters can split messages in hyper
Medium
EPSS 1.03%
>= 0.10.0, < 0.10.2
0.10.2
GHSA-q89x-f52w-6hj2
Headers containing newline characters can split messages in hyper
Medium
EPSS 1.03%
< 0.9.18
0.9.18
GHSA-9xjr-m6f3-v5wm
HTTPS MitM vulnerability due to lack of hostname verification
Medium
EPSS 0.74%
>= 0.0.0-0, < 0.9.4
0.9.4
GHSA-9xjr-m6f3-v5wm
HTTPS MitM vulnerability due to lack of hostname verification
Medium
EPSS 0.74%
< 0.9.4
0.9.4
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor