Skip to content

zope2 (PyPI)

Advisories
12
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.13.19 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "zope2>=2.13.19"
poetry
poetry add "zope2>=2.13.19"
uv
uv add "zope2>=2.13.19"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-48vv-2pmq-9fvv
Plone and Zope2 do not reseed pseudo-random number generator
High
EPSS 2.38%
< 2.13.19
2.13.19
GHSA-48vv-2pmq-9fvv
Plone and Zope2 do not reseed pseudo-random number generator
High
EPSS 2.38%
< 2.13.19
2.13.19
GHSA-77hv-8796-8ccp
HTTP header injection in Plone and Zope2
High
EPSS 2.52%
< 2.13.19
2.13.19
GHSA-77hv-8796-8ccp
HTTP header injection in Plone and Zope2
High
EPSS 2.52%
< 2.13.19
2.13.19
GHSA-879r-7f3w-8jj3
Plone and Zope2 vulnerable to unauthorized access to restricted attributes
Medium
EPSS 1.94%
< 2.12.21
2.12.21
GHSA-879r-7f3w-8jj3
Plone and Zope2 vulnerable to unauthorized access to restricted attributes
Medium
EPSS 1.94%
>= 2.13.0, < 2.13.11
2.13.11
GHSA-879r-7f3w-8jj3
Plone and Zope2 vulnerable to unauthorized access to restricted attributes
Medium
EPSS 1.94%
< 2.12.21
>= 2.13, < 2.13.11
2.12.21
2.13.11
GHSA-3qpr-7rmg-73v8
Plone and Zope2 affected by Race Condition
High
EPSS 1.44%
< 2.13.19
2.13.19
GHSA-3qpr-7rmg-73v8
Plone and Zope2 affected by Race Condition
High
EPSS 1.44%
< 2.13.19
2.13.19
GHSA-p6h9-hpcg-c6gm
High severity vulnerability that affects Plone and Zope2
High
EPSS 2.03%
>= 2.12.0, < 2.12.19
2.12.19
GHSA-p6h9-hpcg-c6gm
High severity vulnerability that affects Plone and Zope2
High
EPSS 2.03%
>= 2.13.0, < 2.13.8
2.13.8
GHSA-p6h9-hpcg-c6gm
High severity vulnerability that affects Plone and Zope2
High
EPSS 2.03%
>= 2.12.0, < 2.12.19
>= 2.13.0, < 2.13.8
2.12.19
2.13.8
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor