GHSA-48vv-2pmq-9fvv CVE-2012-6661 PYSEC-2014-51 PYSEC-2014-76
Plone and Zope2 do not reseed pseudo-random number generator
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 2.38%
- Chance of exploitation in the next 30 days. Higher than 83.89% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-336 Same Seed in Pseudo-Random Number Generator (PRNG)
- Fix
- Available
- 2 packages have a fixed version
Description
Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via unspecified vectors. NOTE: this issue was SPLIT from CVE-2012-5508 due to different vulnerability types (ADT2).
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| plone | >= 3.2.2, < 4.2.3 |
4.2.3 |
| plone | >= 4.3a1, < 4.3b1 |
4.3b1 |
| plone | < 4.2.3>= 4.3a0, < 4.3b1 |
4.2.34.3b1 |
| zope2 | < 2.13.19 |
2.13.19 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
plone PyPI → 4.2.3
- pip
pip install --upgrade "plone>=4.2.3"- poetry
poetry add "plone>=4.2.3"- uv
uv add "plone>=4.2.3"
zope2 PyPI → 2.13.19
- pip
pip install --upgrade "zope2>=2.13.19"- poetry
poetry add "zope2>=2.13.19"- uv
uv add "zope2>=2.13.19"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-336: Same Seed in Pseudo-Random Number Generator (PRNG)
A Pseudo-Random Number Generator (PRNG) uses the same seed each time the product is initialized.
How to prevent it
- Architecture and Design: Do not reuse PRNG seeds. Consider a PRNG that periodically re-seeds itself as needed from a high quality pseudo-random output, such as hardware devices.
- Architecture and Design, Requirements: Use products or modules that conform to FIPS 140-2 [REF-267] to avoid obvious entropy problems, or use the more recent FIPS 140-3 [REF-1192] if possible.
References
Advisories
Packages
Other links
- bugs.launchpad.net/zope2/+bug/1071067
- github.com/plone/Products.CMFPlone/blob/4.2.3/docs/CHANGES.txt
- github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2014-51.yaml
- github.com/pypa/advisory-database/tree/main/vulns/zope2/PYSEC-2014-76.yaml
- plone.org/products/plone-hotfix/releases/20121124
- plone.org/products/plone/security/advisories/20121106/24
- openwall.com/lists/oss-security/2012/11/10/1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xg5p-8wg5-rhxm Phone information disclosure vulnerability | High | Also affects plone |
| GHSA-5xfx-55x4-j223 Cross-Frame Scripting vulnerability has been found on Plone CMS | High | Also affects plone |
| GHSA-47p5-p3jw-w78w Server-Side Request Forgery in Plone CMS | High | Also affects plone |
| GHSA-cvwc-g7fw-7xrj Plone XSS Vulnerability | Medium | Also affects plone |
| GHSA-pwgm-jvqv-6v8p Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable | High | Also affects plone |
| GHSA-46f9-f8jm-mw2x Plone Cross-site Scripting vulnerability in the LiveSearch module | Medium | Also affects plone |
| GHSA-hjp5-hv33-q58g Plone credentials stored in session cookie | Medium | Also affects plone |
| GHSA-593c-j348-f3gv Plone Improper Session Management | High | Also affects plone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor