Skip to content

GHSA-w3x4-9854-95x8 CVE-2017-7297 GO-2023-1973

Rancher Access Control Vulnerability

High Go
Severity
8.8 / 10
High · CVSS 3.1
Exploit chance (EPSS)
1.49%
Chance of exploitation in the next 30 days. Higher than 74.08% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
1.5.3
Upgrade github.com/rancher/rancher to this version or later

Description

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

Affected versions

Go

PackageVulnerableFixed in
github.com/rancher/rancher
>= 1.5.0, < 1.5.3
1.5.3
github.com/rancher/rancher
>= 1.4.0, < 1.4.3
1.4.3
github.com/rancher/rancher
>= 1.3.0, < 1.3.5
1.3.5
github.com/rancher/rancher
>= 1.2.0, < 1.2.4
1.2.4
github.com/rancher/rancher
>= 1.2.0, < 1.2.4
>= 1.3.0, < 1.3.5
>= 1.4.0, < 1.4.3
>= 1.5.0, < 1.5.3
1.2.4
1.3.5
1.4.3
1.5.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

github.com/rancher/rancher Go → 1.5.3

go
go get github.com/rancher/rancher@v1.5.3 && go mod tidy

Severity breakdown

CVSS 3.1 8.8

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-4j6x-2764-m8gh
Rancher has over-inclusive team membership expansion in GitHub App authentication provider
High Also affects github.com/rancher/rancher
GHSA-vx8h-4prv-g744
Rancher has Privilege Escalation from Project Owner to Host
High Also affects github.com/rancher/rancher
GHSA-mhc6-2gfq-xx62
Rancher vulnerable to command injection through unsanitized YAML parameter
Critical Also affects github.com/rancher/rancher
GHSA-5v3h-x4wf-5c35
Rancher Extensions have arbitrary file access via path traversal
High Also affects github.com/rancher/rancher
GHSA-gqf8-rvrh-g7w6
Rancher cloud credentials can be used through proxy API by users without access
Critical Also affects github.com/rancher/rancher
GHSA-hwm2-4ph6-w6m5
Rancher's restricted PodSecurityPolicy does not prevent containers from running as a privileged user
High Also affects github.com/rancher/rancher
GHSA-mc24-7m59-4q5p
Rancher CLI skips TLS verification on Rancher CLI login command
Medium Also affects github.com/rancher/rancher
GHSA-mw39-9qc2-f7mg
Rancher exposes sensitive information through audit logs
Medium Also affects github.com/rancher/rancher
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor