GHSA-m5pm-rgvf-vg22 CVE-2017-7666
Apache OpenMeetings vulnerable to Cross-Site Request Forgery
- Severity
- 8.8 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 0.80%
- Chance of exploitation in the next 30 days. Higher than 56.73% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-352 Cross-Site Request Forgery (CSRF)
- Fix
3.3.0- Upgrade org.apache.openmeetings:openmeetings-parent to this version or later
Description
Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks. The issue is fixed in version 3.3.0.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.openmeetings:openmeetings-parent | >= 1.0.0, < 3.3.0 |
3.3.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.openmeetings:openmeetings-parent Maven → 3.3.0
- maven
<dependency><groupId>org.apache.openmeetings</groupId><artifactId>openmeetings-parent</artifactId><version>3.3.0</version></dependency>- gradle
implementation("org.apache.openmeetings:openmeetings-parent:3.3.0")
Severity breakdown
CVSS 3.0 8.8
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-352: Cross-Site Request Forgery (CSRF)
The web application does not, or cannot, sufficiently verify whether a request was intentionally provided by the user who sent the request, which could have originated from an unauthorized actor.
How to prevent it
- Architecture and Design: Use a vetted library or framework that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid [REF-1482]. For example, use anti-CSRF packages such as the OWASP CSRFGuard. [REF-330] Another example is the ESAPI Session Management control, which includes a component for CSRF. [REF-45]
- Implementation: Ensure that the application is free of cross-site scripting issues (CWE-79), because most CSRF defenses can be bypassed using attacker-controlled script.
- Architecture and Design: Generate a unique nonce for each form, place the nonce into the form, and verify the nonce upon receipt of the form. Be sure that the nonce is not predictable (CWE-330). [REF-332]
- Architecture and Design: Identify especially dangerous operations. When the user performs a dangerous operation, send a separate confirmation request to ensure that the user intended to perform that operation.
- Architecture and Design: Use the "double-submitted cookie" method as described by Felten and Zeller: When a user visits a site, the site should generate a pseudorandom value and set it as a cookie on the user's machine. The site should require every form submission to include this value as a form value and also as a cookie value. When a POST request is sent to the site, the request should only be considered valid if the form value and the cookie value are the same. Because of the same-origin policy, an attacker cannot read or modify the value stored in the cookie. To successfully submit a form on behalf of the user, the attacker would have to correctly guess the pseudorandom value. If the pseudorandom value is cryptographically strong, this will be prohibitively difficult. This technique requires Javascript, so it may not work for browsers that have Javascript disabled. [REF-331]
- Architecture and Design: Do not use the GET method for any request that triggers a state change.
- Implementation: Check the HTTP Referer header to see if the request originated from an expected page. This could break legitimate functionality, because users or proxies may have disabled sending the Referer for privacy reasons.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gcvm-c75m-h4p4 Apache OpenMeetings Uses GET Request Method With Sensitive Query Strings | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-wqxq-w68r-wg85 Apache OpenMeetings Uses Hard-coded Cryptographic Key | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-78cg-fc6c-w44w Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mjf9-4pcv-vfg7 Apache OpenMeetings vulnerable to Deserialization of Untrusted Data | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mg5h-f3q8-c96g Apache OpenMeetings vulnerable to remote code execution via null-bye injection | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-v9rm-7rv9-r3fw Apache OpenMeetings Improper Authentication vulnerability | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-3r48-3m8r-4r9w Apache OpenMeetings missing authentication and can allow user impersonation | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-pxj9-mw96-q634 Apache OpenMeetings Cross-site Scripting vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor