Skip to content

GHSA-78cg-fc6c-w44w CVE-2026-33005

Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability

Medium Maven
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.42%
Chance of exploitation in the next 30 days. Higher than 36.15% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-274 Improper Handling of Insufficient Privileges
Fix
9.0.0
Upgrade org.apache.openmeetings:openmeetings-parent to this version or later

Description

Sny registered user can query web service with their credentials and get files/sub-folders of any folder by ID (metadata only NOT contents). Metadata includes id, type, name and some other field. Full list of fields get be checked at FileItemDTO object.

This issue affects Apache OpenMeetings: from 3.10 before 9.0.0.

Users are recommended to upgrade to version 9.0.0, which fixes the issue.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.openmeetings:openmeetings-parent
>= 3.10, < 9.0.0
9.0.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.openmeetings:openmeetings-parent Maven → 9.0.0

maven
<dependency><groupId>org.apache.openmeetings</groupId><artifactId>openmeetings-parent</artifactId><version>9.0.0</version></dependency>
gradle
implementation("org.apache.openmeetings:openmeetings-parent:9.0.0")

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
Low
Integrity (vulnerable system)
None
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 4.3

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None

Weakness

CWE-274: Improper Handling of Insufficient Privileges

The product does not handle or incorrectly handles when it has insufficient privileges to perform an operation, leading to resultant weaknesses.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gcvm-c75m-h4p4
Apache OpenMeetings Uses GET Request Method With Sensitive Query Strings
High Also affects org.apache.openmeetings:openmeetings-parent
GHSA-wqxq-w68r-wg85
Apache OpenMeetings Uses Hard-coded Cryptographic Key
High Also affects org.apache.openmeetings:openmeetings-parent
GHSA-mjf9-4pcv-vfg7
Apache OpenMeetings vulnerable to Deserialization of Untrusted Data
Critical Also affects org.apache.openmeetings:openmeetings-parent
GHSA-mg5h-f3q8-c96g
Apache OpenMeetings vulnerable to remote code execution via null-bye injection
High Also affects org.apache.openmeetings:openmeetings-parent
GHSA-v9rm-7rv9-r3fw
Apache OpenMeetings Improper Authentication vulnerability
High Also affects org.apache.openmeetings:openmeetings-parent
GHSA-3r48-3m8r-4r9w
Apache OpenMeetings missing authentication and can allow user impersonation
Critical Also affects org.apache.openmeetings:openmeetings-parent
GHSA-pxj9-mw96-q634
Apache OpenMeetings Cross-site Scripting vulnerability
Medium Also affects org.apache.openmeetings:openmeetings-parent
GHSA-m5pm-rgvf-vg22
Apache OpenMeetings vulnerable to Cross-Site Request Forgery
High Also affects org.apache.openmeetings:openmeetings-parent
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor