Skip to content

org.apache.activemq:activemq-broker (Maven)

Advisories
21
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 6.2.6 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-broker</artifactId><version>6.2.6</version></dependency>
gradle
implementation("org.apache.activemq:activemq-broker:6.2.6")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-hf52-78x8-6w3w
Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability
Medium
EPSS 0.37%
< 5.19.7
5.19.7
GHSA-hf52-78x8-6w3w
Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability
Medium
EPSS 0.37%
>= 6.0.0, < 6.2.6
6.2.6
GHSA-v853-w46p-fv2h
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High
EPSS 0.60%
>= 6.0.0, < 6.2.6
6.2.6
GHSA-v853-w46p-fv2h
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High
EPSS 0.60%
< 5.19.7
5.19.7
GHSA-hg6c-8mvr-jqc9
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High
EPSS 0.74%
< 5.19.7
5.19.7
GHSA-hg6c-8mvr-jqc9
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ have a Code Injection issue
High
EPSS 0.74%
>= 6.0.0, < 6.2.6
6.2.6
GHSA-mr6m-xj7v-3cv3
Apache ActiveMQ Vulnerable to Code Injection
High
EPSS 0.98%
< 5.19.6
5.19.6
GHSA-mr6m-xj7v-3cv3
Apache ActiveMQ Vulnerable to Code Injection
High
EPSS 0.98%
>= 6.0.0, < 6.2.5
6.2.5
GHSA-2jp3-2923-9h52
Apache ActiveMQ Vulnerable to Cross-site Scripting
Medium
EPSS 0.56%
< 5.19.6
5.19.6
GHSA-2jp3-2923-9h52
Apache ActiveMQ Vulnerable to Cross-site Scripting
Medium
EPSS 0.56%
>= 6.0.0, < 6.2.5
6.2.5
GHSA-w3w2-mpp5-92gm
Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection
High
EPSS 4.78%
>= 6.0.0, < 6.2.5
6.2.5
GHSA-w3w2-mpp5-92gm
Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection
High
EPSS 4.78%
< 5.19.6
5.19.6
GHSA-5568-6qcg-g7fx
Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
High
EPSS 0.90%
< 5.19.4
5.19.4
GHSA-5568-6qcg-g7fx
Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
High
EPSS 0.90%
>= 6.0.0, < 6.2.4
6.2.4
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
Known exploited
High
EPSS 98.26%
< 5.19.5
5.19.5
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
Known exploited
High
EPSS 98.26%
>= 6.0.0, < 6.2.3
6.2.3
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
Known exploited
High
EPSS 98.26%
< 5.19.5
5.19.5
GHSA-rxpj-7qvf-xv32
Authenticated Apache ActiveMQ Broker and Apache ActiveMQ users could perform RCE via Jolokia MBeans
Known exploited
High
EPSS 98.26%
>= 6.0.0, < 6.2.3
6.2.3
GHSA-h2h4-5m64-m273
Apache ActiveMQ: Improper validation and restriction of a classpath path name
Medium
EPSS 0.42%
>= 6.0.0, < 6.2.2
6.2.2
GHSA-h2h4-5m64-m273
Apache ActiveMQ: Improper validation and restriction of a classpath path name
Medium
EPSS 0.42%
< 5.19.3
5.19.3
GHSA-4vhf-2hv7-8mrx
Improper Restriction of XML External Entity Reference in Apache ActiveMQ
Critical
EPSS 8.18%
>= 5.0.0, < 5.10.1
5.10.1
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor