GHSA-g233-2p4r-3q7v BIT-openbao-2024-8185 BIT-vault-2024-8185 CVE-2024-8185 GO-2024-3246
Hashicorp Vault vulnerable to denial of service through memory exhaustion
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 0.48%
- Chance of exploitation in the next 30 days. Higher than 41.15% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-636 Not Failing Securely ('Failing Open')
- Fix
- Available
- 2 packages have a fixed version
Description
Vault Community and Vault Enterprise (“Vault”) clusters using Vault’s Integrated Storage backend are vulnerable to a denial-of-service (DoS) attack through memory exhaustion through a Raft cluster join API endpoint. An attacker may send a large volume of requests to the endpoint which may cause Vault to consume excessive system memory resources, potentially leading to a crash of the underlying system and the Vault process itself.
This vulnerability, CVE-2024-8185, is fixed in Vault Community 1.18.1 and Vault Enterprise 1.18.1, 1.17.8, and 1.16.12.
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/hashicorp/vault | >= 1.2.0, < 1.18.1 |
1.18.1 |
| github.com/openbao/openbao | < 2.0.3 |
2.0.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/hashicorp/vault Go → 1.18.1
- go
go get github.com/hashicorp/vault@v1.18.1 && go mod tidy
github.com/openbao/openbao Go → 2.0.3
- go
go get github.com/openbao/openbao@v2.0.3 && go mod tidy
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-636: Not Failing Securely ('Failing Open')
When the product encounters an error condition or failure, its design requires it to fall back to a state that is less secure than other options that are available, such as selecting the weakest encryption algorithm or using the most permissive access control restrictions.
How to prevent it
- Architecture and Design: Subdivide and allocate resources and components so that a failure in one part does not affect the entire product.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xp3c-3jw3-4vcr OpenBao Skips Stricter Deny Policy for LIST operations | Medium | Also affects github.com/openbao/openbao |
| GHSA-34fc-gh42-pj53 OpenBao's Recovery Mode Vulnerable To Token Leakage via Timing Attack | Critical | Also affects github.com/openbao/openbao |
| GHSA-444v-8vxr-p36h OpenBao Agent Writes Secrets to Stdout | Low | Also affects github.com/openbao/openbao |
| GHSA-59w7-v8rr-pr4p OpenBao's Templated Policies Allow Privilege Escalation via Wildcard Characters | High | Also affects github.com/openbao/openbao |
| GHSA-8w8f-r2xv-4q4j OpenBao: Transit secrets engine crashes on key creation with `derived: true` for asymmetric key types | Medium | Also affects github.com/openbao/openbao |
| GHSA-mwr2-wmgp-crj6 OpenBao's System Backend allows Unauthorized Management of the containing Namespace | Low | Also affects github.com/openbao/openbao |
| GHSA-c36x-h252-g9x2 OpenBao: Cross-namespace lease revocation/renewal via canonical sys/leases/{revoke,renew} — incomplete fix of CVE-2026-45808 | Low | Also affects github.com/openbao/openbao |
| GHSA-6mwx-4547-5vc9 OpenBao: LDAPi ldaputil (wrong escape func) | Medium | Also affects github.com/openbao/openbao |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor