GHSA-f632-9449-3j4w BIT-tomcat-2024-52318 CVE-2024-52318
Apache Tomcat - XSS in generated JSPs
- Severity
- 6.1 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 1.88%
- Chance of exploitation in the next 30 days. Higher than 79.45% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-326 Inadequate Encryption Strength
- Fix
- Available
- 3 packages have a fixed version
Description
Description:
The fix for improvement 69333 caused pooled JSP tags not to be released after use which in turn could cause output of some tags not to escaped as expected. This unescaped output could lead to XSS.
Versions Affected:
- Apache Tomcat 11.0.0
- Apache Tomcat 10.1.31
- Apache Tomcat 9.0.96
Mitigation:
Users of the affected versions should apply one of the following mitigations:
- Upgrade to Apache Tomcat 11.0.1 or later
- Upgrade to Apache Tomcat 10.1.33 or later Note: 10.1.32 was not released
- Upgrade to Apache Tomcat 9.0.97 or later
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-jasper | >= 9.0.96, < 9.0.97 |
9.0.97 |
| org.apache.tomcat.embed:tomcat-embed-jasper | >= 11.0.0, < 11.0.1 |
11.0.1 |
| org.apache.tomcat.embed:tomcat-embed-jasper | >= 10.1.31, < 10.1.32 |
10.1.32 |
| org.apache.tomcat:tomcat | >= 11.0.0, < 11.0.1 |
11.0.1 |
| org.apache.tomcat:tomcat | >= 10.1.31, < 10.1.32 |
10.1.32 |
| org.apache.tomcat:tomcat | >= 9.0.96, < 9.0.97 |
9.0.97 |
| org.apache.tomcat:tomcat-jasper | >= 11.0.0, < 11.0.1 |
11.0.1 |
| org.apache.tomcat:tomcat-jasper | >= 10.1.31, < 10.1.32 |
10.1.32 |
| org.apache.tomcat:tomcat-jasper | >= 9.0.96, < 9.0.97 |
9.0.97 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-jasper Maven → 9.0.97
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-jasper</artifactId><version>9.0.97</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-jasper:9.0.97")
org.apache.tomcat:tomcat Maven → 11.0.1
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>11.0.1</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat:11.0.1")
org.apache.tomcat:tomcat-jasper Maven → 11.0.1
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-jasper</artifactId><version>11.0.1</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-jasper:11.0.1")
Severity breakdown
CVSS 3.1 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Changed
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-326: Inadequate Encryption Strength
The product stores or transmits sensitive data using an encryption scheme that is theoretically sound, but is not strong enough for the level of protection required.
How to prevent it
- Architecture and Design: Use an encryption scheme that is currently considered to be strong by experts in the field.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/8d1fc4733a06d1a03b9d644c57010f2ec5f0df38
- github.com/apache/tomcat/commit/9813c5dd3259183f659bbb83312a5cf673cc1ebf
- github.com/apache/tomcat/commit/be8e32143a3159e78fe5463d09bb8e1b33bf2b1f
- bz.apache.org/bugzilla/show_bug.cgi
- lists.apache.org/thread/co243cw1nlh6p521c5265cm839wkqdp9
- security.netapp.com/advisory/ntap-20250131-0009
- openwall.com/lists/oss-security/2024/11/18/4
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability | High Known exploited | Also affects org.apache.tomcat:tomcat |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-9xv2-5v5q-p794 Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-gcx9-497g-6cp6 Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-5m62-pw8w-7w9f Apache Tomcat - Security constraints not correctly applied | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-9m89-8frq-c98c Apache Tomcat - AJP secret compared in non-constant time | Low | Also affects org.apache.tomcat:tomcat |
| GHSA-5mp6-jrq3-r938 Apache Tomcat: LockOutRealm treats user names as case-sensitive | High | Also affects org.apache.tomcat:tomcat |
| GHSA-h6fc-48rj-7qqh Apache Tomcat - Digest authenticator will authenticate any unknown user | Critical | Also affects org.apache.tomcat:tomcat |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor