GHSA-h6fc-48rj-7qqh BIT-tomcat-2026-43512 CVE-2026-43512
Apache Tomcat - Digest authenticator will authenticate any unknown user
- Severity
- 9.8 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 1.33%
- Chance of exploitation in the next 30 days. Higher than 70.98% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
- Available
- 3 packages have a fixed version
Description
Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.0.M1 to 9.0.117 Older, unsupported versions may also be affected
Description: When DIGEST authentication was configured, any user not known to the configured Realm would be authenticated if they presented the password "null".
Mitigation: Users of the affected versions should apply one of the following mitigations:
- Upgrade to Apache Tomcat 11.0.22 or later
- Upgrade to Apache Tomcat 10.1.55 or later
- Upgrade to Apache Tomcat 9.0.118 or later
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | < 9.0.118 |
9.0.118 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 10.1.0-M1, < 10.1.55 |
10.1.55 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.0-M1, < 11.0.22 |
11.0.22 |
| org.apache.tomcat:tomcat | < 9.0.118 |
9.0.118 |
| org.apache.tomcat:tomcat | >= 10.1.0-M1, < 10.1.55 |
10.1.55 |
| org.apache.tomcat:tomcat | >= 11.0.0-M1, < 11.0.22 |
11.0.22 |
| org.apache.tomcat:tomcat-catalina | < 9.0.118 |
9.0.118 |
| org.apache.tomcat:tomcat-catalina | >= 10.1.0-M1, < 10.1.55 |
10.1.55 |
| org.apache.tomcat:tomcat-catalina | >= 11.0.0-M1, < 11.0.22 |
11.0.22 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-core Maven → 9.0.118
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>9.0.118</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:9.0.118")
org.apache.tomcat:tomcat Maven → 9.0.118
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>9.0.118</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat:9.0.118")
org.apache.tomcat:tomcat-catalina Maven → 9.0.118
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-catalina</artifactId><version>9.0.118</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-catalina:9.0.118")
Severity breakdown
CVSS 3.1 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Other links
- github.com/apache/tomcat/commit/3d4d3fae07a6cd9c2eb193c5491001740ec64448
- github.com/apache/tomcat/commit/6565a6cb6499e56fe2f34457cec99f9d1c4f39e9
- github.com/apache/tomcat/commit/a99c355e8199adbfd67c9a1fffbd85b810b196cd
- lists.apache.org/thread/7x09x7o12solvclslw3sz0288xc8wx73
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
- openwall.com/lists/oss-security/2026/05/12/8
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability | High Known exploited | Also affects org.apache.tomcat:tomcat |
| GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-qppj-fm5r-hxr3 HTTP/2 Stream Cancellation Attack | Medium Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-xjgh-84hx-56c5 Unrestricted Upload of File with Dangerous Type Apache Tomcat | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-cw54-59pw-4g8c Apache Tomcat Improper Access Control vulnerability | Critical Known exploited | Also affects org.apache.tomcat:tomcat-catalina |
| CVE-2020-1938 Improper Privilege Management in Tomcat | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-pjfr-qf3p-3q25 When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor