Skip to content

GHSA-gcx9-497g-6cp6 BIT-tomcat-2026-65182 CVE-2026-65182

Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability

Critical Maven
Severity
9.1 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
0.65%
Chance of exploitation in the next 30 days. Higher than 51.32% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-284 Improper Access Control
Fix
Available
3 packages have a fixed version

Description

Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.

Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.tomcat.embed:tomcat-embed-core
>= 11.0.0-M1, < 11.0.25
11.0.25
org.apache.tomcat.embed:tomcat-embed-core
>= 10.1.0-M1, < 10.1.58
10.1.58
org.apache.tomcat.embed:tomcat-embed-core
>= 9.0.0-M1, < 9.0.121
9.0.121
org.apache.tomcat.embed:tomcat-embed-core
>= 8.5.0, <= 8.5.100
No fix yet
org.apache.tomcat.embed:tomcat-embed-core
>= 7.0.0, <= 7.0.109
No fix yet
org.apache.tomcat:tomcat
>= 11.0.0-M1, < 11.0.25
11.0.25
org.apache.tomcat:tomcat
>= 10.1.0-M1, < 10.1.58
10.1.58
org.apache.tomcat:tomcat
>= 9.0.0-M1, < 9.0.121
9.0.121
org.apache.tomcat:tomcat
>= 8.5.0, <= 8.5.100
No fix yet
org.apache.tomcat:tomcat
>= 7.0.0, <= 7.0.109
No fix yet
org.apache.tomcat:tomcat-catalina
>= 11.0.0-M1, < 11.0.25
11.0.25
org.apache.tomcat:tomcat-catalina
>= 10.1.0-M1, < 10.1.58
10.1.58
org.apache.tomcat:tomcat-catalina
>= 9.0.0-M1, < 9.0.121
9.0.121
org.apache.tomcat:tomcat-catalina
>= 8.5.0, <= 8.5.100
No fix yet
org.apache.tomcat:tomcat-catalina
>= 7.0.0, <= 7.0.109
No fix yet

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.tomcat.embed:tomcat-embed-core Maven → 11.0.25

maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>11.0.25</version></dependency>
gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:11.0.25")

org.apache.tomcat:tomcat Maven → 11.0.25

maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>11.0.25</version></dependency>
gradle
implementation("org.apache.tomcat:tomcat:11.0.25")

org.apache.tomcat:tomcat-catalina Maven → 11.0.25

maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-catalina</artifactId><version>11.0.25</version></dependency>
gradle
implementation("org.apache.tomcat:tomcat-catalina:11.0.25")

Severity breakdown

CVSS 3.1 9.1

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
None

Weakness

CWE-284: Improper Access Control

The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor.

How to prevent it
  • Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
High Known exploited Also affects org.apache.tomcat:tomcat
GHSA-83qj-6fr2-vhqg
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
Critical Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-qppj-fm5r-hxr3
HTTP/2 Stream Cancellation Attack
Medium Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-xjgh-84hx-56c5
Unrestricted Upload of File with Dangerous Type Apache Tomcat
High Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-cw54-59pw-4g8c
Apache Tomcat Improper Access Control vulnerability
Critical Known exploited Also affects org.apache.tomcat:tomcat-catalina
CVE-2020-1938
Improper Privilege Management in Tomcat
Critical Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-pjfr-qf3p-3q25
When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server
High Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-h3x4-894j-xpx5
Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability
Critical Also affects org.apache.tomcat.embed:tomcat-embed-core
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor