GHSA-cv9j-7q4x-v2g2 CVE-2018-1286
Apache OpenMeetings may allow authenticated attacker to deny service for privileged users
- Severity
- 6.5 / 10
- Medium · CVSS 3.0
- Exploit chance (EPSS)
- 1.08%
- Chance of exploitation in the next 30 days. Higher than 65.26% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
4.0.2- Upgrade org.apache.openmeetings:openmeetings-parent to this version or later
Description
In Apache OpenMeetings 3.0.0 - 4.0.1, CRUD operations on privileged users are not password protected allowing an authenticated attacker to deny service for privileged users. The issue is fixed in version 4.0.2.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.openmeetings:openmeetings-parent | >= 3.0.0, < 4.0.2 |
4.0.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.openmeetings:openmeetings-parent Maven → 4.0.2
- maven
<dependency><groupId>org.apache.openmeetings</groupId><artifactId>openmeetings-parent</artifactId><version>4.0.2</version></dependency>- gradle
implementation("org.apache.openmeetings:openmeetings-parent:4.0.2")
Severity breakdown
CVSS 3.0 6.5
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gcvm-c75m-h4p4 Apache OpenMeetings Uses GET Request Method With Sensitive Query Strings | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-wqxq-w68r-wg85 Apache OpenMeetings Uses Hard-coded Cryptographic Key | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-78cg-fc6c-w44w Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mjf9-4pcv-vfg7 Apache OpenMeetings vulnerable to Deserialization of Untrusted Data | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mg5h-f3q8-c96g Apache OpenMeetings vulnerable to remote code execution via null-bye injection | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-v9rm-7rv9-r3fw Apache OpenMeetings Improper Authentication vulnerability | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-3r48-3m8r-4r9w Apache OpenMeetings missing authentication and can allow user impersonation | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-pxj9-mw96-q634 Apache OpenMeetings Cross-site Scripting vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor