Skip to content

GHSA-crg9-44h2-xw35 BIT-activemq-2023-46604 CVE-2023-46604

Apache ActiveMQ is vulnerable to Remote Code Execution

Critical Known exploited Maven
Severity
10.0 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
99.99%
Chance of exploitation in the next 30 days. Higher than 99.99% of scored vulnerabilities.
Known exploited
Yes
In CISA's catalog since Nov 2, 2023
Weakness
CWE-502 Deserialization of Untrusted Data
Fix
Available
2 packages have a fixed version
Exploited in the wild. Apache ActiveMQ Deserialization of Untrusted Data Vulnerability (Apache ActiveMQ). Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. Due for U.S. federal agencies by Nov 23, 2023. Known to be used in ransomware campaigns.

Description

Apache ActiveMQ is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker with network access to a broker to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause the broker to instantiate any class on the classpath. 

Users are recommended to upgrade to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3, which fixes this issue.

Affected versions

Maven

PackageVulnerableFixed in
org.apache.activemq:activemq-client
< 5.15.16
5.15.16
org.apache.activemq:activemq-client
>= 5.16.0, < 5.16.7
5.16.7
org.apache.activemq:activemq-client
>= 5.17.0, < 5.17.6
5.17.6
org.apache.activemq:activemq-client
>= 5.18.0, < 5.18.3
5.18.3
org.apache.activemq:activemq-client
< 5.15.16
5.15.16
org.apache.activemq:activemq-client
>= 5.16.0, < 5.16.7
5.16.7
org.apache.activemq:activemq-client
>= 5.17.0, < 5.17.6
5.17.6
org.apache.activemq:activemq-client
>= 5.18.0, < 5.18.3
5.18.3
org.apache.activemq:activemq-openwire-legacy
>= 5.8.0, < 5.15.16
5.15.16
org.apache.activemq:activemq-openwire-legacy
>= 5.16.0, < 5.16.7
5.16.7
org.apache.activemq:activemq-openwire-legacy
>= 5.17.0, < 5.17.6
5.17.6
org.apache.activemq:activemq-openwire-legacy
>= 5.18.0, < 5.18.3
5.18.3
org.apache.activemq:activemq-openwire-legacy
>= 5.8.0, < 5.15.16
5.15.16
org.apache.activemq:activemq-openwire-legacy
>= 5.16.0, < 5.16.7
5.16.7
org.apache.activemq:activemq-openwire-legacy
>= 5.17.0, < 5.17.6
5.17.6
org.apache.activemq:activemq-openwire-legacy
>= 5.18.0, < 5.18.3
5.18.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.activemq:activemq-client Maven → 5.15.16

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-client</artifactId><version>5.15.16</version></dependency>
gradle
implementation("org.apache.activemq:activemq-client:5.15.16")

org.apache.activemq:activemq-openwire-legacy Maven → 5.15.16

maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-openwire-legacy</artifactId><version>5.15.16</version></dependency>
gradle
implementation("org.apache.activemq:activemq-openwire-legacy:5.15.16")

Severity breakdown

CVSS 3.1 10.0

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H/E:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Changed
Confidentiality
Low
Integrity
High
Availability
High
Exploit maturity
H

Weakness

CWE-502: Deserialization of Untrusted Data

The product deserializes untrusted data without sufficiently ensuring that the resulting data will be valid.

How to prevent it
  • Architecture and Design, Implementation: If available, use the signing/sealing features of the programming language to assure that deserialized data has not been tainted. For example, a hash-based message authentication code (HMAC) could be used to ensure that data has not been modified.
  • Implementation: When deserializing data, populate a new object rather than just deserializing. The result is that the data flows through safe input validation and that the functions are safe.
  • Implementation: Explicitly define a final object() to prevent deserialization.
  • Architecture and Design, Implementation: Make fields transient to protect them from deserialization. An attempt to serialize and then deserialize a class containing transient fields will result in NULLs where the transient data should be. This is an excellent way to prevent time, environment-based, or sensitive variables from being carried over and used improperly.
  • Implementation: Avoid having unnecessary types or gadgets (a sequence of instances and method invocations that can self-execute during the deserialization process, often found in libraries) available that can be leveraged for malicious ends. This limits the potential for unintended or unauthorized types and gadgets to be leveraged by the attacker. Add only acceptable classes to an allowlist. Note: new gadgets are constantly being discovered, so this alone is not a sufficient mitigation.
  • Architecture and Design, Implementation: Employ cryptography of the data or code for protection. However, it's important to note that it would still be client-side security. This is risky because if the client is compromised then the security implemented on the client (the cryptography) can be bypassed.
  • Operation: Use an application firewall that can detect attacks against this weakness. It can be beneficial in cases in which the code cannot be fixed (because it is controlled by a third party), as an emergency prevention measure while more comprehensive software assurance measures are applied, or to provide defense in depth [REF-1481].

References

Timeline

  1. Published
  2. Added to CISA's Known Exploited Vulnerabilities catalog
  3. Remediation due for U.S. federal agencies
  4. Last updated by the source
  5. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-rxqh-fc23-gxp2
Improper Input Validation in Apache ActiveMQ
Critical Known exploited Also affects org.apache.activemq:activemq-client
GHSA-5568-6qcg-g7fx
Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
High Also affects org.apache.activemq:activemq-client
GHSA-h2h4-5m64-m273
Apache ActiveMQ: Improper validation and restriction of a classpath path name
Medium Also affects org.apache.activemq:activemq-client
GHSA-whxr-3p84-rf3c
Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
High Also affects org.apache.activemq:activemq-client
GHSA-p358-58jj-hp65
Improper Authentication in Apache ActiveMQ
Medium Also affects org.apache.activemq:activemq-client
GHSA-mfhr-3xmc-r2gg
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium Also affects org.apache.activemq:activemq-client
GHSA-3wfj-vh84-732p
Improper Neutralization of Special Elements used in an OS Command in Apache ActiveMQ
High Also affects org.apache.activemq:activemq-client
GHSA-9cvr-8xq4-2m73
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium Also affects org.apache.activemq:activemq-client

Credits: nmarcoccio, sunSUNQ

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor