org.apache.activemq:activemq-openwire-legacy (Maven)
Advisories
12
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.1.6 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-openwire-legacy</artifactId><version>6.1.6</version></dependency>gradle
implementation("org.apache.activemq:activemq-openwire-legacy:6.1.6")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-whxr-3p84-rf3c Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation |
High EPSS 8.96% |
< 5.16.8 | 5.16.8 |
| GHSA-whxr-3p84-rf3c Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation |
High EPSS 8.96% |
>= 5.17.0, < 5.17.7 | 5.17.7 |
| GHSA-whxr-3p84-rf3c Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation |
High EPSS 8.96% |
>= 5.18.0, < 5.18.7 | 5.18.7 |
| GHSA-whxr-3p84-rf3c Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation |
High EPSS 8.96% |
>= 6.0.0, < 6.1.6 | 6.1.6 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.8.0, < 5.15.16 | 5.15.16 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.16.0, < 5.16.7 | 5.16.7 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.8.0, < 5.15.16 | 5.15.16 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.18.0, < 5.18.3 | 5.18.3 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.17.0, < 5.17.6 | 5.17.6 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.16.0, < 5.16.7 | 5.16.7 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.17.0, < 5.17.6 | 5.17.6 |
| GHSA-crg9-44h2-xw35 Apache ActiveMQ is vulnerable to Remote Code Execution Known exploited |
Critical EPSS 99.99% |
>= 5.18.0, < 5.18.3 | 5.18.3 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor