Skip to content

org.apache.activemq:activemq-client (Maven)

Advisories
35
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 6.2.4 or later clears every advisory below that has a fix.

Upgrade commands
maven
<dependency><groupId>org.apache.activemq</groupId><artifactId>activemq-client</artifactId><version>6.2.4</version></dependency>
gradle
implementation("org.apache.activemq:activemq-client:6.2.4")

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-5568-6qcg-g7fx
Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
High
EPSS 0.90%
< 5.19.4
5.19.4
GHSA-5568-6qcg-g7fx
Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
High
EPSS 0.90%
>= 6.0.0, < 6.2.4
6.2.4
GHSA-h2h4-5m64-m273
Apache ActiveMQ: Improper validation and restriction of a classpath path name
Medium
EPSS 0.42%
>= 6.0.0, < 6.2.2
6.2.2
GHSA-h2h4-5m64-m273
Apache ActiveMQ: Improper validation and restriction of a classpath path name
Medium
EPSS 0.42%
< 5.19.3
5.19.3
GHSA-whxr-3p84-rf3c
Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
High
EPSS 8.96%
< 5.16.8
5.16.8
GHSA-whxr-3p84-rf3c
Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
High
EPSS 8.96%
>= 6.0.0, < 6.1.6
6.1.6
GHSA-whxr-3p84-rf3c
Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
High
EPSS 8.96%
>= 5.18.0, < 5.18.7
5.18.7
GHSA-whxr-3p84-rf3c
Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
High
EPSS 8.96%
>= 5.17.0, < 5.17.7
5.17.7
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.16.0, < 5.16.7
5.16.7
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
< 5.15.16
5.15.16
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.16.0, < 5.16.7
5.16.7
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.17.0, < 5.17.6
5.17.6
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.18.0, < 5.18.3
5.18.3
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
< 5.15.16
5.15.16
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.17.0, < 5.17.6
5.17.6
GHSA-crg9-44h2-xw35
Apache ActiveMQ is vulnerable to Remote Code Execution
Known exploited
Critical
EPSS 99.99%
>= 5.18.0, < 5.18.3
5.18.3
GHSA-p358-58jj-hp65
Improper Authentication in Apache ActiveMQ
Medium
EPSS 6.31%
< 5.8.0
5.8.0
GHSA-mfhr-3xmc-r2gg
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 6.42%
< 5.9.0
5.9.0
GHSA-x6rc-54xp-ccxx
Withdrawn Advisory: Improper Restriction of XML External Entity Reference in Apache ActiveMQ
Withdrawn
Critical
< 2.23.1
2.23.1
GHSA-4vhf-2hv7-8mrx
Improper Restriction of XML External Entity Reference in Apache ActiveMQ
Critical
EPSS 8.18%
>= 5.0.0, < 5.10.1
5.10.1
GHSA-9cvr-8xq4-2m73
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 7.14%
>= 5.0.0, < 5.10.1
5.10.1
GHSA-3wfj-vh84-732p
Improper Neutralization of Special Elements used in an OS Command in Apache ActiveMQ
High
EPSS 12.79%
< 5.11.0
5.11.0
GHSA-8rcq-p4gh-vmj8
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 6.07%
>= 5.12.0, < 5.12.3
5.12.3
GHSA-rxqh-fc23-gxp2
Improper Input Validation in Apache ActiveMQ
Known exploited
Critical
EPSS 98.52%
>= 5.0.0, < 5.14.0
5.14.0
GHSA-3v63-f83x-37x4
Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ
Medium
EPSS 84.41%
>= 5.0.0, < 5.11.2
5.11.2
GHSA-8rcq-p4gh-vmj8
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 6.07%
>= 5.0.0, < 5.11.4
5.11.4
GHSA-rxqh-fc23-gxp2
Improper Input Validation in Apache ActiveMQ
Known exploited
Critical
EPSS 98.52%
>= 5.0.0, < 5.14.0
5.14.0
GHSA-8rcq-p4gh-vmj8
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 6.07%
>= 5.13.0, < 5.13.2
5.13.2
GHSA-w525-w93j-rxgm
Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Medium
EPSS 8.62%
>= 5.0.0, < 5.13.2
5.13.2
GHSA-5jg4-p78r-p5j3
Improper Neutralization of Input During Web Page Generation Apache ActiveMQ
Medium
EPSS 6.09%
>= 5.0.0, < 5.14.2
5.14.2
GHSA-q9hr-3pg4-3jp4
Improper Input Validation in Apache ActiveMQ
Critical
EPSS 38.19%
>= 5.12.0, < 5.12.2
5.12.2
GHSA-q9hr-3pg4-3jp4
Improper Input Validation in Apache ActiveMQ
Critical
EPSS 38.19%
>= 5.0.0, < 5.11.3
5.11.3
GHSA-jvpp-hxjj-5ccc
Improper Input Validation and Missing Authentication for Critical Function in Apache ActiveMQ
Medium
EPSS 1.97%
< 5.14.5
5.14.5
GHSA-jpv3-g4cc-6vfx
Improper Control of Generation of Code ('Code Injection') in org.apache.activemq:activemq-client
High
EPSS 12.03%
>= 5.0.0, < 5.15.9
5.15.9
GHSA-m9w8-v359-9ffr
Improper Certificate Validation in Apache activemq-client
High
EPSS 6.96%
< 5.15.6
5.15.6
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor