GHSA-95jq-rwvf-vjx4 BIT-tomcat-2026-29145 CVE-2026-29145
Apache Tomcat: CLIENT_CERT authentication does not fail as expected
- Severity
- 9.1 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 0.71%
- Chance of exploitation in the next 30 days. Higher than 53.74% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
- Available
- 2 packages have a fixed version
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.
Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat:tomcat | >= 9.0.83, < 9.0.116 |
9.0.116 |
| org.apache.tomcat:tomcat | >= 10.1.0-M7, < 10.1.53 |
10.1.53 |
| org.apache.tomcat:tomcat | >= 11.0.0-M1, < 11.0.20 |
11.0.20 |
| org.apache.tomcat:tomcat-coyote-ffm | >= 9.0.83, < 9.0.116 |
9.0.116 |
| org.apache.tomcat:tomcat-coyote-ffm | >= 10.1.0-M7, < 10.1.53 |
10.1.53 |
| org.apache.tomcat:tomcat-coyote-ffm | >= 11.0.0-M1, < 11.0.20 |
11.0.20 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat:tomcat Maven → 9.0.116
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>9.0.116</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat:9.0.116")
org.apache.tomcat:tomcat-coyote-ffm Maven → 9.0.116
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-coyote-ffm</artifactId><version>9.0.116</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-coyote-ffm:9.0.116")
Severity breakdown
CVSS 3.1 9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/721591f7bff424c693f26adc18ae9b9abac3655b
- github.com/apache/tomcat/commit/d1406df5ae0326f39f54c3f64ac30d8fca55cd5b
- github.com/apache/tomcat/commit/fe26667cd2385045ac73f4dea086cc9971209b90
- lists.apache.org/thread/yz5fxmhd2j43wgqykssdo7kltws57jfz
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
- openwall.com/lists/oss-security/2026/04/09/23
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability | High Known exploited | Also affects org.apache.tomcat:tomcat |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-9xv2-5v5q-p794 Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-gcx9-497g-6cp6 Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-5m62-pw8w-7w9f Apache Tomcat - Security constraints not correctly applied | Critical | Also affects org.apache.tomcat:tomcat |
| GHSA-9m89-8frq-c98c Apache Tomcat - AJP secret compared in non-constant time | Low | Also affects org.apache.tomcat:tomcat |
| GHSA-5mp6-jrq3-r938 Apache Tomcat: LockOutRealm treats user names as case-sensitive | High | Also affects org.apache.tomcat:tomcat |
| GHSA-h6fc-48rj-7qqh Apache Tomcat - Digest authenticator will authenticate any unknown user | Critical | Also affects org.apache.tomcat:tomcat |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor