GHSA-7ff4-jw48-3436 BIT-openbao-2025-64761 CVE-2025-64761 GO-2025-4156
OpenBao is Vulnerable to Privileged Operator Identity Group Root Escalation
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 0.39%
- Chance of exploitation in the next 30 days. Higher than 33.11% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Fix
2.4.4- Upgrade github.com/openbao/openbao to this version or later
Description
Impact
Similar to HCSEC-2025-13 / CVE-2025-5999, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when:
- An operator in the root namespace has access to
identity/groupsendpoints. - An operator does not have policy access.
Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability.
Patches
Patched in version 2.4.4.
Workarounds
Users should audit the use of identity subsystem and deny operators access if it is not in use.
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/openbao/openbao | < 2.4.4 |
2.4.4 |
| github.com/openbao/openbao | all versions |
No fix yet |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/openbao/openbao Go → 2.4.4
- go
go get github.com/openbao/openbao@v2.4.4 && go mod tidy
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- Present
- Privileges required
- High
- User interaction
- None
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-266: Incorrect Privilege Assignment
A product incorrectly assigns a privilege to a particular actor, creating an unintended sphere of control for that actor.
How to prevent it
- Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
- Architecture and Design, Operation: Run your code using the lowest privileges that are required to accomplish the necessary tasks [REF-76]. If possible, create isolated accounts with limited privileges that are only used for a single task. That way, a successful attack will not immediately give the attacker access to the rest of the software or its environment. For example, database applications rarely need to run as the database administrator, especially in day-to-day operations.
CWE-269: Improper Privilege Management
The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.
How to prevent it
- Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
- Architecture and Design: Follow the principle of least privilege when assigning access rights to entities in a software system.
- Architecture and Design: Consider following the principle of separation of privilege. Require multiple conditions to be met before permitting access to a system resource.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xp3c-3jw3-4vcr OpenBao Skips Stricter Deny Policy for LIST operations | Medium | Also affects github.com/openbao/openbao |
| GHSA-34fc-gh42-pj53 OpenBao's Recovery Mode Vulnerable To Token Leakage via Timing Attack | Critical | Also affects github.com/openbao/openbao |
| GHSA-444v-8vxr-p36h OpenBao Agent Writes Secrets to Stdout | Low | Also affects github.com/openbao/openbao |
| GHSA-59w7-v8rr-pr4p OpenBao's Templated Policies Allow Privilege Escalation via Wildcard Characters | High | Also affects github.com/openbao/openbao |
| GHSA-8w8f-r2xv-4q4j OpenBao: Transit secrets engine crashes on key creation with `derived: true` for asymmetric key types | Medium | Also affects github.com/openbao/openbao |
| GHSA-mwr2-wmgp-crj6 OpenBao's System Backend allows Unauthorized Management of the containing Namespace | Low | Also affects github.com/openbao/openbao |
| GHSA-c36x-h252-g9x2 OpenBao: Cross-namespace lease revocation/renewal via canonical sys/leases/{revoke,renew} — incomplete fix of CVE-2026-45808 | Low | Also affects github.com/openbao/openbao |
| GHSA-6mwx-4547-5vc9 OpenBao: LDAPi ldaputil (wrong escape func) | Medium | Also affects github.com/openbao/openbao |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor