GHSA-67q3-gwww-pm4g CVE-2017-7664
Apache OpenMeetings does not correctly validate uploaded XML documents
- Severity
- 10.0 / 10
- Critical · CVSS 3.0
- Exploit chance (EPSS)
- 2.35%
- Chance of exploitation in the next 30 days. Higher than 83.66% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-611 Improper Restriction of XML External Entity Reference
- Fix
3.3.0- Upgrade org.apache.openmeetings:openmeetings-parent to this version or later
Description
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0. The issue is fixed in version 3.3.0.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.openmeetings:openmeetings-parent | >= 3.1.0, < 3.3.0 |
3.3.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.openmeetings:openmeetings-parent Maven → 3.3.0
- maven
<dependency><groupId>org.apache.openmeetings</groupId><artifactId>openmeetings-parent</artifactId><version>3.3.0</version></dependency>- gradle
implementation("org.apache.openmeetings:openmeetings-parent:3.3.0")
Severity breakdown
CVSS 3.0 10.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Changed
- Confidentiality
- Low
- Integrity
- High
- Availability
- High
Weakness
CWE-611: Improper Restriction of XML External Entity Reference
The product processes an XML document that can contain XML entities with URIs that resolve to documents outside of the intended sphere of control, causing the product to embed incorrect documents into its output.
How to prevent it
- Implementation, System Configuration: Many XML parsers and validators can be configured to disable external entity expansion.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gcvm-c75m-h4p4 Apache OpenMeetings Uses GET Request Method With Sensitive Query Strings | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-wqxq-w68r-wg85 Apache OpenMeetings Uses Hard-coded Cryptographic Key | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-78cg-fc6c-w44w Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mjf9-4pcv-vfg7 Apache OpenMeetings vulnerable to Deserialization of Untrusted Data | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mg5h-f3q8-c96g Apache OpenMeetings vulnerable to remote code execution via null-bye injection | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-v9rm-7rv9-r3fw Apache OpenMeetings Improper Authentication vulnerability | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-3r48-3m8r-4r9w Apache OpenMeetings missing authentication and can allow user impersonation | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-pxj9-mw96-q634 Apache OpenMeetings Cross-site Scripting vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor