GHSA-4vvc-r4p4-qgrr CVE-2023-48796 PYSEC-2023-268
Apache DolphinScheduler sensitive information disclosure
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.19%
- Chance of exploitation in the next 30 days. Higher than 67.99% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
- Available
- 2 packages have a fixed version
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler.
The information exposed to unauthorized actors may include sensitive data such as database credentials.
Users who can't upgrade to the fixed version can also set environment variable MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus to workaround this, or add the following section in the application.yaml file
management:
endpoints:
web:
exposure:
include: health,metrics,prometheus
This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.dolphinscheduler:dolphinscheduler | >= 3.0.0, < 3.0.2 |
3.0.2 |
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-dolphinscheduler | >= 3.0.0, < 3.0.2 |
3.0.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.dolphinscheduler:dolphinscheduler Maven → 3.0.2
- maven
<dependency><groupId>org.apache.dolphinscheduler</groupId><artifactId>dolphinscheduler</artifactId><version>3.0.2</version></dependency>- gradle
implementation("org.apache.dolphinscheduler:dolphinscheduler:3.0.2")
apache-dolphinscheduler PyPI → 3.0.2
- pip
pip install --upgrade "apache-dolphinscheduler>=3.0.2"- poetry
poetry add "apache-dolphinscheduler>=3.0.2"- uv
uv add "apache-dolphinscheduler>=3.0.2"
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-72mv-wwvm-vgp5 Apache DolphinScheduler has an Incorrect Authorization Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-f786-9c63-8xr8 Apache DolphinScheduler RPC module has a Deserialization of Untrusted Data vulnerability | Medium | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3cjc-vhfm-ffp2 Apache DolphinScheduler vulnerable to sensitive information disclosure | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-rrpj-r8h7-rm7r Apache DolphinScheduler Incorrect Default Permissions Vulnerability | Critical | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3vcp-r62v-xpvg Apache DolphinScheduler vulnerable to Alert Script Attack | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-4vv4-crw4-8pcw Apache DolphinScheduler: Resource File Read And Write Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-m9q4-p56m-mc6q Apache DolphinScheduler: RCE by arbitrary js execution | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-ff2w-wm48-jhqj Arbitrary File Read Vulnerability in Apache Dolphinscheduler | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor