apache-dolphinscheduler (PyPI)
Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.0.2 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "apache-dolphinscheduler>=3.0.2"poetry
poetry add "apache-dolphinscheduler>=3.0.2"uv
uv add "apache-dolphinscheduler>=3.0.2"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-4vvc-r4p4-qgrr Apache DolphinScheduler sensitive information disclosure |
High EPSS 1.19% |
>= 3.0.0, < 3.0.2 | 3.0.2 |
| GHSA-4vvc-r4p4-qgrr Apache DolphinScheduler sensitive information disclosure |
High EPSS 1.19% |
>= 3.0.0, < 3.0.2 | 3.0.2 |
| GHSA-3xh5-8hvq-rc8x Apache DolphinScheduler vulnerable to Improper Input Validation |
Critical EPSS 2.66% |
< 3.0.2 | 3.0.2 |
| GHSA-qg5x-66hp-cw5p Uncontrolled Resource Consumption in Apache DolphinScheduler |
High EPSS 1.98% |
< 2.0.5 | 2.0.5 |
| GHSA-qg5x-66hp-cw5p Uncontrolled Resource Consumption in Apache DolphinScheduler |
High EPSS 1.98% |
< 2.0.5 | 2.0.5 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor