GHSA-4v67-wg88-37p9 CVE-2017-7683
Apache OpenMeetings displays Tomcat version and detailed error stack trace
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 2.00%
- Chance of exploitation in the next 30 days. Higher than 80.72% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
3.3.0- Upgrade org.apache.openmeetings:openmeetings-parent to this version or later
Description
Apache OpenMeetings 1.0.0 displays Tomcat version and detailed error stack trace, which is not secure. The issue is fixed in version 3.3.0.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.openmeetings:openmeetings-parent | >= 1.0.0, < 3.3.0 |
3.3.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.openmeetings:openmeetings-parent Maven → 3.3.0
- maven
<dependency><groupId>org.apache.openmeetings</groupId><artifactId>openmeetings-parent</artifactId><version>3.3.0</version></dependency>- gradle
implementation("org.apache.openmeetings:openmeetings-parent:3.3.0")
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gcvm-c75m-h4p4 Apache OpenMeetings Uses GET Request Method With Sensitive Query Strings | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-wqxq-w68r-wg85 Apache OpenMeetings Uses Hard-coded Cryptographic Key | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-78cg-fc6c-w44w Apache OpenMeetings has an Improper Handling of Insufficient Privileges vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mjf9-4pcv-vfg7 Apache OpenMeetings vulnerable to Deserialization of Untrusted Data | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-mg5h-f3q8-c96g Apache OpenMeetings vulnerable to remote code execution via null-bye injection | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-v9rm-7rv9-r3fw Apache OpenMeetings Improper Authentication vulnerability | High | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-3r48-3m8r-4r9w Apache OpenMeetings missing authentication and can allow user impersonation | Critical | Also affects org.apache.openmeetings:openmeetings-parent |
| GHSA-pxj9-mw96-q634 Apache OpenMeetings Cross-site Scripting vulnerability | Medium | Also affects org.apache.openmeetings:openmeetings-parent |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor